Ostatnie zmiany

(c) Logotech AA

Wersja 25.01.047 (09.10.2025)

  • W pełnomocnictwie PEL zmieniliśmy opisy na identyczne z wzorcem ZUS.
  • Na prośbę użytkowników dodaliśmy możliwość wpisania stanu zapłaty dokumentu przez wpisanie kodów zapłaty 0,1 lub 2. Jeżeli nie chcemy wybierać stanu zapłaty klawiszem Insert, to wystarczy w opisie stanu wpisać jego kod i przejść do następnego pola edycyjnego. Ksp bada pierwszy wpisany znak (reszta jest bez znaczenia)
  • Dodaliśmy import sprzedaży z platformy językowej "LangLion", z pliku excel.

Wersja 25.01.046 (09.10.2025)

  • Dodano nową opcję "F/4/8.Wynagrodzenie płatnika". Zaznaczamy w niej za które miesiące należy potrącić wynagrodzenie płatnika. Jeżeli wybierzemy potrącanie wówczas podczas wydruku podsumowania oraz deklaracji PIT-4R program wykaże potrącenie wynagrodzenia w wysokości 0.3% należnych zaliczek podatku. Jeżeli kwota wyliczona przez Ksp będzie się różnić od kwoty faktycznie potrąconej za ubiegłe miesiące, należy po wybraniu miesiąca, w opcji "D/7.Eksport do płatnika" wybrać przelew i tam wpisać faktycznie potrącaną kwotę. Tę kwotę program wykaże na deklaracji PIT-4R.
  • Przywrócono funkcjonalność pobrania kontrahenta z CIDG (ctrl+Ins). Na niektórych formatkach przestało działać po aktualizacji.
  • Zaktualizowano tabelę odsetek.
  • Dokonano kilku drobnych poprawek związanych ze zmianami formatek w związku z KSeF.

Wersja 25.01.045 (07.10.2025)

  • W październiku 2022 znowelizowano ustawę o ryczałcie i doprecyzowano, że złe długi powstają jedynie od niezapłaconych zakupów towarów handlowych. Uwzględniamy to niniejszej wersji Ksp.
  • Z uwagi na tworzenie przez oprogramowanie apteczne pliku z danymi o zakupach która posiada błąd struktury, Ksp będzie go naprawiać przy imporcie danych z kamsoftu (do czasu aż błąd zostanie usunięty).
  • Na formatce z zasiłkami z umów zlecenie dodaliśmy pole z potrąceniem komorniczym.
  • Zmieniliśmy formatkę w magazynie samochodów. Obecnie oprócz sprzedaży można wycofać samochód z magazynu
  • Zmieniliśmy kilkadziesiąt formatek dostosowując je do Systemu Ksef. Staną się w pełni aktywne po odblokowaniu opcji "Ksef".

Wersja 25.01.044 (22.09.2025)

  • W nagłówku świadectwa pracy zamiast regonu i PKD będziemy podawać numer NIP (W związku ze zmianami PKD nie trzeba będzie przed wydrukiem kontrolować tej zmiennej)
  • Na formatce nr 4 w opcji "A/6.Parametry instalacyjne" dodano informację od kiedy i do kiedy podatnik stosuje opodatkowanie marży na zasadach marży łącznej. Informacja potrzebna nam jest do wstępnej dekretacji bufora z pobranymi fakturami sprzedaży KSeF.
  • Poprawiono formatkę z rachunkami do umowy zlecenie, za pracę za granicą do 183 dni. Po naciśnięciu klawisza Insert w polu z kwotą do wypłaty na formatce przez chwilę pokazywały się dane nie w tych co potrzeba miejscach edycyjnych.
  • Do rozrachunków walutowych dodano nową opcję "Rozchód na inny własny rachunek". Jeżeli posiadamy kilka rachunków walutowych w tej samej walucie, to przekazanie kwoty z jednego rachunku na inny nie powinno skutkować naliczeniem różnic kursowych. W Ksp nie mieliśmy takiej możliwości bowiem każdy rozchód z rachunku walutowego powodował powstanie różnic kursowych typu fifo/lifo, podczas gdy rozchód z rachunku powinien się odbyć po kursie z dnia powstania przychodu (a więc bez różnic). Ksp przy każdym rozchodzie z rachunku odszukuje metodą fifo/lifo odpowiednie przychody i w ten sposób ustala kurs po jakim waluta pojawiła się na rachunku i porównuje go z kursem z dnia rozchodu ustalając odpowiednie różnice. Dodanie nowej opcji przesunięcia środków pomiędzy rachunkami spowoduje, że Ksp przyjmie identyczny kurs rozchodu jaki miał powiązany z nim przychód. W ten sposób różnice kursowe nie będą powstawać. Problem w tym, że na drugim rachunku powinien powstać przychód (przychody) z identycznym kursem jak na rachunku pierwszym. Jeżeli wiec rozchód waluty odbywa się z kilku przychodów to na drugim rachunku powinno się pojawić również kilka przychodów. To znacznie komplikuje operację. Na szczęście można tu stosować kurs uśredniony, a więc zamiast kilku przychodów po różnych kursach na drugim rachunku dodajemy jeden przychód z uśrednionym kursem. Naliczenie różnic kursowych odbywa się w Ksp zawsze podczas zamknięcia raportu bankowego. I tu pojawia się następny problem bowiem niezależne dotychczas 2 rachunki walutowe stają się powiązane przez operację przesunięcia środków. Naliczenie różnic powinno być zatem zsynchronizowane. Jak to przebiega w praktyce?. Rachunkiem sterującym (nadrzędnym) będzie zawsze rachunek, z którego odbywa się rozchód. Po wpisaniu daty, kwoty, opisu i wybraniu rachunku, na który przesuwamy środki Ksp oznaczy taki rekord rozchodu jako "przesunięcie" i dopisze na drugim rachunku identyczny z tą samą kwotą, tyle że po stronie przychodowej. Na tym etapie odpowiednie zapisy nie będą jeszcze miały właściwych kursów, bowiem te ustalane są dopiero na etapie zamykania raportu. Tym niemniej na rachunku, na którym powstał przychód odpowiedni rekord można edytować wpisując własny kurs waluty. Rekordu przychodowego nie można usunąć. Jedynie usunięcie rekordu rozchodowego usuwa również rekord przychodowy na powiązanym rachunku. Należy również pamiętać, że raport bankowy można zamknąć tylko wtedy, gdy dla wszystkich rekordów tego raportu jest możliwe ustalenie kursu waluty. Np. jeżeli z rachunku A przesuniemy środki na Rachunek B w dniu x, a w dniu następnym (x+1) dokonamy przesunięcia z B na A, to na rachunku A nie będzie możliwe zamknięcie raportu na dzień x+1 bowiem nie będzie znany kurs przychodu B na A. A więc najpierw trzeba będzie zamknąć raport na rachunku A z datą x (wtedy zostanie ustalony kurs przychodu na rachunku B), następnie z datą x+1 trzeba zamknąć raport na rachunku B i dopiero potem zamknąć raport na rachunku A z datą x+1.
  • Opcja przesunięcia środków dostępna jest dla metody FiFo. Jeśli będzie taka potrzeba dodamy ją również dla metody LiFo.
  • Zaktualizowano tabelę odsetek.

Wersja 25.01.043 (31.08.2025)

  • Poprawiono wydruk ewidencji do rozliczenia vat marża w turystyce złożonej. Program zawsze pokazywał podatek vat od marży w wysokości 23% zamiast tylko od tej części marży, która jest opodatkowana tą stawką. Sprzedaż do księgi przekazywana była poprawnie.
  • W wydruku ilości pracowników w firmach (narzędzia operatora) dodano kolumnę z ilością pracowników, którym zostało wypłacone wynagrodzenie za wybrany miesiąc, co odpowiada ilości zatrudnionych w tym miesiącu.
  • Przy obliczaniu składki na fundusz pracy dla pracowników zatrudnionych na pełen etat, gdy ustawiony jest parametr "nie licz, gdy wynagrodzenie < płacy minimalnej" program będzie zawsze naliczał składkę na FP. Dotychczas porównywał podstawę składki z płaca minimalną, która podczas choroby jest wyższa od otrzymanego wynagrodzenia o ile okres choroby (zasiłku) zawiera również niedziele i święta. ęrół

Wersja 25.01.042 (13.08.2025)

  • Na prośbę użytkowników, w opcji z listą płac dla umów zlecenie, dodano odrębną opcję (F5) dla zapisywania każdego rachunku w odrębnym pliku pdf, lub pakowania go do pliku zip z hasłem, lub wysyłania spakowanych lub nie, plików pdf na adres e-mail każdego pracownika lub adres firmowy. Podobnie jak ma to miejsce dla list płac z umów o pracę. Dotychczas można to było zrobić przy wydruku zbiorczym rachunków.
  • Do narzędzi operatora dodaliśmy zestawienie firm, które w wybranym miesiącu dokonały wypłaty wynagrodzeń z tytułu umowy o pracę lub innych umów cywilnoprawnych. Zestawienie zawiera ilości dokonanych wypłat z poszczególnych tytułów.
  • W OSS uwzględniono zmianę stawki podstawowej VAT w Estonii z 22% na 24% (od lipca) i w Rumunii z 19% na 21% (od sierpnia)
  • Przygotowując się do zmian w limitach amortyzacji i zaliczaniu do kosztów raty kapitałowej i ubezpieczeniowej leasingu samochodów osobowych, który od 2026 roku będzie zależał od wysokości emisji CO2 ( [g/km]), wprowadziliśmy na formatce nr 3 w edycji danych samochodu (2/2/3/4.Rejestr samochodów) informację o tej emisji.

Wersja 25.01.041 (04.08.2025)

  • Na życzenie użytkowników zmieniliśmy sposób informowania programu o naliczaniu bądź nie naliczaniu składki na Fundusz pracy. Obecnie należy wybrać jedną z 3 opcji:
    • Zawsze naliczać: Program zawsze naliczy składkę na FP o ile zleceniobiorca będzie młodszy niż 55/60 lat.
    • Nigdy nie licz: Program nie będzie naliczał składki bez względu na inne okoliczności
    • Tylko gdy > min: program naliczy składkę tylko gdy na umowie nie określono miesięcznej stawki lub gdy ta stawka jest mniejsza od płacy minimalnej oraz osiągnięte wynagrodzenie w danym miesiącu będzie mniejsze od płacy minimalnej.
  • Po instalacji programu parametr pozostaje bez zmiany, a więc przyjmuje wartość zawsze naliczaj albo nigdy nie naliczaj. Gdy naliczanie ma być uzależnione od wysokości wypłaconego wynagrodzenia trzeba to zaznaczyć na umowie wybierając (Insert) odpowiednią opcję.

Wersja 25.01.040 (29.07.2025)

  • Poprawa błędu występującego przy wyborze komornika na formatce z zajęciem komorniczym. Nowy komornik nie pozwalał się zapisać w bazie.

Wersja 25.01.038 (25.07.2025)

  • Poprawiono błąd, polegający na tym, że w umowach zlecenie składkę na FGŚP uzależniono od składki na FP. Jeśli składka na FP była równa 0 to Ksp przyjmował również 0 dla składki na FGŚP.
  • W opcji z "D/6/4/2.Lista potrąceń ustawowych." dodano opcję (F5) "Przelewy do komorników". Dla każdego pracownika, u którego w danym miesiącu występowały zajęcia komornicze, program zsumuje je i utworzy plik przelewów w formacie Elixir-0 z konta firmowego na konto komornika. Na formatce z tytułem potrącenia dodaliśmy pole w, którym decydujemy czy dla danego "tytułu" tworzyć przelew komorniczy czy też nie. Istnieją sytuacje w których zajętego wynagrodzenia nie przekazujemy komornikowi, tylko tworzymy dla niego zastaw sądowy.
  • W opcji "D/1.Podstawowa lista płac (obliczenia)" dodaliśmy dwie opcje (F5 - H. i J.). Obydwie tworzą plik raportujący do Urzędu Pracy listę pracowników z wyliczoną przez program kwota refundowanych wynagrodzeń i składek Zus pracodawcy. Plik może być utworzony w formacie pliku tekstowego rtf lub pliku excel. W tym drugim przypadku użytkownik powinien posiadać zainstalowane oprogramowanie excel.
  • Aby program mógł obliczyć refundowane kwoty należy odpowiednie parametry tej refundacji wprowadzić dla każdego pracownika w opcji z zestawami płacowymi na formatce nr 4. Podajemy tam wartość maksymalnej kwoty refundacji oraz zakres miesięcy (od, do) za które wypłacone pracownikowi wynagrodzenie jest refundowane.

Wersja 25.01.037 (22.07.2025)

  • Przy imporcie faktur zakupowych w formacie Symfonii uwzględniliśmy ich nowe oznaczenia, dotychczas nie występujące w formacie wersji 4.0
  • Przy imporcie sprzedaży OSS w formacie subiekta (epp) uwzględniono nietypowe odstępstwa od ustalonego formatu (dodatkowe puste wiersze).
  • Jeżeli w umowie zlecenie zaznaczono, aby program naliczał składkę na FP i FGŚP, program niezależnie od wysokości wynagrodzenia tę składkę naliczał. Obecnie składka nie będzie naliczana, jeżeli:
    • W umowie nie określono kwoty wynagrodzenia miesięcznego i suma podstaw składek na ub. społeczne w danym miesiącu będzie mniejsza niż płaca minimalna;
    • W umowie określono kwotę wynagrodzenia miesięcznego i kwota tego wynagrodzenia jest mniejsza od płacy minimalnej, oraz suma podstaw składek na ub. społeczne w danym miesiącu będzie mniejsza niż płaca minimalna.
  • Jeżeli została zawarta umowa zlecenie z własnym pracownikiem, za którego naliczane są składki na FEP, to do podstawy tych składek zostanie dodane wynagrodzenie z tytułu umowy zlecenia. Uwaga! Składki FEP są liczone podczas obliczania wynagrodzenia z tytułu umowy o pracę, oraz w opcji "eksport danych do płatnika", przy wejściu do opcji i przy zmianie miesiąca.

Wersja 25.01.036 (20.06.2025)

  • Przy eksporcie danych do SODiR uwzględniono przebywanie na urlopie bezpłatnym obniżającym maksymalną kwotę dofinansowania.

Wersja 25.01.035 (09.06.2025)

  • Dodano import faktur z programu sky-Shop w formacie csv.
  • Dodano możliwość zapisania składek PPK w pliku w formacie csv (dotychczas było tylko w xml). Nie możemy zagwarantować, że dane o składkach w tym formacie zaimportują się do aplikacji funduszu. O ile format xml jest wspólny dla wszystkich funduszy, o tyle format csv może być inny dla każdego z funduszy. Jest to zapisane w porozumieniu Grupy PPK. Nie sprawdzaliśmy czy tak jest w istocie. Nasz format odpowiada wzorcowemu formatowi csv, który wypracowała GRUPA Projektowa PPK zrzeszająca większość instytucji finansowych prowadzących obecnie fundusze PPK.
  • Przy wprowadzaniu dokumentu raty leasingowej dla samochodów osobowych umożliwiliśmy wpisanie dokumentu z kwotami ujemnymi.

Wersja 25.01.033 (22.05.2025)

  • Do wydruku faktur z paragonem w ewidencji Vat, dodaliśmy informację o GTU i Procedurach
  • Przy sumowaniu dokumentów w księdze dodaliśmy informację o ogólnej sumie Brutto dokumentów (zaznaczonych lub wszystkich)
  • W umowach zlecenie dodaliśmy do zasiłku macierzyńskiego kod 329 - czyli podwyższenie kwoty zasiłku macierzyńskiego do kwoty świadczenia rodzicielskiego.
  • W opcji sprzedaży towarów na zasadach vat-marża dodaliśmy możliwość zaimportowania dokumentów z pliku excel. Format pliku udostępnimy na życzenie chętnym użytkownikom. Po od naciśnięciu klawisza F5 Ksp poprosi o wskazanie pliku z importowanymi dokumentami a następnie doda je do sprzedaży vat marża/komis i dopisze powiązane ze sprzedażą towary do magazynu vat marża. Jeżeli importowane dokumenty będą już w Ksp, to zostaną pominięte. Dla każdego importowanego dokumentu tworzony jest Id na podstawie zawartych danych. To Id wpisywane jest do tabeli z dokumentami w Ksp. Jeżeli importowany dokument ma identyczne Id jak to zapisane w bazie Ksp, to nie jest importowany. Taki dokument jest oznaczony wykrzyknikiem w kolumnie "K". Zaznaczenie/odznaczenie dokumentu powoduje, że w kolumnie "K" na powrót pojawia się oznaczenie typu sprzedaży K-Komis U-towary używane. Importowane zostaną wyłącznie te dokumenty dla których data sprzedaży jest większa lub równa dacie ostatnio zaksięgowanego dokumentu w Ksp (dacie dokumentu któremu nadano nr Lp). Dodatkowo, nie będzie można dopisać dokumentu na zamknięty miesiąc.
  • W normach podatkowych zaktualizowaliśmy kwoty wolne od potrąceń z zasiłków.

Wersja 25.01.032 (16.05.2025)

  • Niektóre programy sprzedażowe tworzyły pliki xml w sposób niezgodny ze standardem tego pliku. Te nietypowe sytuacje uwzględniliśmy w Ksp, co pozwala nam zaimportować dane o sprzedaży i zakupach w większym zakresie.
  • Niektóre programy sprzedażowe tworząc plik wymiany danych w formacie vat_r.txt (stary format CDN) wpisywały w zakupach znacznik, który wskazywał, że zakup dotyczy środków trwałych. Aktualnie wykluczyliśmy taką sytuację i nie interpretujemy tego znacznika. Każdy zakup będzie umieszczany w ewidencji zakupów VAT jako "pozostałe zakupy".
  • W opcji zakupu paliwa, leasingu i ubezpieczenia AC dla samochodów dodaliśmy klawisz Insert, który działa na kwocie netto faktury. Klawisz ten uruchamia kalkulator walutowy do przeliczania kwot w walucie na złotówki.

Wersja 25.01.031 (08.05.2025)

  • W opcji definiowania dodatkowych składników wynagrodzenia, gdy wybierzemy opcję składnika obliczanego algorytmem, rozszerzyliśmy pola do definicji algorytmu do 165 znaków.
  • Jeśli działalność jest prowadzona przez osobę fizyczną mającą powyżej 20-tu pracowników (zasiłki wypłaca pracodawca) i właściciel posiada osoby współpracujące, które pobierają wynagrodzenie, to Ksp dla osoby współpracującej przebywającej na zasiłku tworzył deklarację RSA ujmując w niej kwotę wypłacanego zasiłku, co jest błędem, bo zasiłek dla takiej osoby wypłaca Zus. Dodatkowo, jeżeli wypłaty dokonywane były w następnym miesiącu, to Ksp wykazywał absencję chorobową z poprzedniego miesiąca zamiast z miesiąca, za który składana jest deklaracja. Innymi słowy traktował osobę współpracującą jak zwykłego pracownika z kodem 0110.

Wersja 25.01.030 (29.04.2025)

  • Na życzenie jednego z biur rachunkowych sparametryzowaliśmy sposób rozliczania złych długów w podatku dochodowym dla przedsiębiorcy, który wybrał ryczałt ewidencjonowany. W opcji "8/B. Parametry księgowania" dodaliśmy 9-ta formatkę danych, na której możemy zdecydować o sposobie rozliczania złych długów. Mamy do dyspozycji:
    • 0: To domyślny sposób rozliczania, taki jak stosowany był dotychczas. A mianowicie: jeżeli w danym miesiącu saldo złych długów czyli: Kwota = Nal_zap  Nal_nzap + Zob_nzap - Zob_zap < 0
      • kwota niezapłaconej należności w 91 dniu liczonym od dnia terminu zapłaty zmniejsza przychód do opodatkowania, będzie to -Nal_nzap (minus wskazuje na ujemną kwotę)
      • Kwota zapłaconej należności, gdy zapłata następuje po miesiącu, w którym wykazaliśmy ujemny zły dług, czyli kwotę z pozycji wyżej. Kwotę te nazwiemy Nal_zap. Kwota ta zwiększa nam przychód do opodatkowania.
      • Kwota niezapłaconego zobowiązania w 91 dniu liczonym od dnia terminu zapłaty zwiększa przychód do opodatkowania, będzie to Zob_nzap ( ta kwota zwiększa przychód do opodatkowania)
      • Kwota zapłaconego zobowiązania, gdy zapłata następuje po miesiącu, w którym wykazaliśmy dodatni zły dług, czyli kwotę z pozycji wyżej. Kwotę te nazwiemy -Zob_zap. Kwota ta zmniejsza przychód do opodatkowania (minus wskazuje na ujemną kwotę)
      To Kwota wynikająca z powyższej zależności zmniejszy przychód do opodatkowania do wysokości tego przychodu, a ściślej rzecz ujmując Kwota dzielona jest na stawki podatku zryczałtowanego wg rocznej struktury sprzedaży i od przychodów z każdej stawki odejmowana jest właściwa część Kwoty przypadająca na daną stawkę do wysokości przychodu wg tej stawki. Pozostałą część złego długu będzie można rozliczyć dopiero w zeznaniu rocznym. Gdyby się okazało, że nie jest możliwe ustalenie rocznej struktury sprzedaży (np. brak sprzedaży), złe długi nie są uwzględniane. Złe długi nie są rozliczane również, gdy Kwota jest dodatnia i brakuje struktury sprzedaży.
    • 1: Zasada rozliczania podobna jest do tej opisanej wyżej (0), z tą różnicą, że jeżeli istnieje roczna struktura sprzedaży, ale Kwota podzielona wg niej na stawki ryczałtu będzie większa od przychodu, to nierozliczona część salda złego długu przejdzie na następny miesiąc. (np. gdy przychód wg danej stawki będzie równy 100, a Kwota= -1100) to na następny miesiąc przejdzie kwota -1000. Te kolejne przesunięcia nierozliczonego salda złych długów będą się dokonywać, aż zły dług rozliczy się w całości. Ta metoda jest znacznie korzystniejsza dla podatnika.
    • 2: I wreszcie metoda najbardziej korzystna, która w większości przypadków prowadzi do całkowitego rozliczenia złego długu. Różni się od metody 1 tylko tym, że do podziału salda złych długów (Kwota) będziemy się posługiwać miesięczną strukturą sprzedaży a nie roczną.
  • Do listy funkcji które można wykorzystać podczas definiowania składników wynagrodzenia obliczanych algorytmem, dodaliśmy funkcję Z_wyn(nr,mc). Funkcja jest podobna do S_wyn(nr,okres), Przy czym o ile S_wyn podaje sumę wybranego elementu wynagrodzenia (nr) z podanego okresu (ilość miesięcy poprzedzających miesiąc za który obliczane jest wynagrodzenie), to funkcja Z_wyn(nr,mc) podaje wartość wybranego składnika (nr) z miesiąca poprzedzającego miesiąc za który obliczamy wypłatę o mc miesięcy. Np. załóżmy, że obliczamy wynagrodzenia za marzec 2025, wówczas Z_wyn(1,2) oznacza stawkę miesięczną z umowy o pracę obowiązującą w miesiącu styczeń 2025. Szczegółowe informacje o poszczególnych elementach wynagrodzenia i ich właściwych numerach, można uzyskać wciskając klawisze ALT+H na formatce z definiowanym algorytmem.

Wersja 25.01.029 (25.04.2025)

  • Poprawa błędu występującego przy próbie wydrukowania faktury przez biuro rachunkowe dla kontrahenta z kartoteki kontrahentów (nie klientów biura). Program raportował błąd systemowy.
  • Jeśli w miesiącu kwietniu prowadzący działalność skorzystał z wakacji Zus, jak wiadomo powinien złożyć 2 deklaracje RCA jedną z kodem 0510 i drugą 0514, ale tylko na deklaracji 0510 powinno się znaleźć roczne rozliczenie składki zdrowotnej. Ksp "z rozpędu" umieszczało je również na tej drugiej deklaracji, co było błędem.

Wersja 25.01.028 (23.04.2025)

  • W opcji z ewidencją SME dodaliśmy 2 zestawienia. Pierwsze to zestawienie sprzedaży SME za okres wybranego kwartału i drugie to zestawienie sprzedaży do zaksięgowania w księdze przychodów.
  • Jeszcze jedna poprawka związana z numerem firmy. Na wydruku faktury drukował się numer folderu z firmą zamiast jej numer logiczny (taki jak w menu wyboru firmy).
  • Przy definiowanych składnikach wynagrodzenia wyrażonych algorytmem dodaliśmy funkcję Z_Abs(nr,mc). W tej funkcji parametr:
    • Nr: oznacza nr elementu związanego z czasem pracy zgodnie z wykazem dostępnym po naciśnięciu klawiszy ALT+H i dostępnym przy opisie funkcji S_abs() i Z_abs(). Np. nr=9 oznacza nominalny czas pracy wyrażony w godzinach a nr=17 ilość dni roboczych przebywania na zwolnieniu chorobowym, za który wypłacane jest wynagrodzenie chorobowe.
    • Mc: oznacza o ile miesięcy trzeba się cofnąć względem miesiąca, za który obliczane jest wynagrodzenie. Np. 1 będzie oznaczać miesiąc poprzedni. Przykładowo, jeśli obliczamy wynagrodzenie za miesiąc styczeń 2025 i użyjemy w definicji składnika funkcji Z_abs(18,2), to będzie oznaczać, że funkcja zwróci nam ilość dni kalendarzowych przebywania na chorobowym w miesiącu listopadzie 2024, za które wypłacono wynagrodzenie chorobowe.

Wersja 25.01.027 (16.04.2025)

  • Ponieważ od stycznia tego roku każdy kraj Unii może wprowadzić zwolnienie z obowiązku rejestrowania się do VAT w swoim kraju o ile obroty podmiotu, który ubiega się o tę możliwość na terenie całej unii w roku poprzednim i bieżącym nie przekroczyły limitu 100tys EUR, dodaliśmy do Ksp możliwość prowadzenia odpowiedniej ewidencji. Słowo "może" jest tu kluczowe, np. Hiszpania nie daje takiej możliwości. Każdy z krajów może wprowadzić odpowiedni limit obrotów na swoim terenie, którego nieprzekroczenie uprawnia podmiot z innego kraju Unii do ubiegania się o zwolnienie z podatku vat na terenie tego kraju o ile nie przekroczy limitu obrotów w tym kraju i suma obrotów we wszystkich krajach Unii (w tym we własnym kraju) będzie mniejsza od 100tys Eur. Limit obrotów w danym kraju unii uprawniający do zwolnienia nie powinien być wyższy niż 85tys EUR. Podmiot polski ubiegający się o zwolnienie w innym kraju Unii będziemy nazywać SME. Kraje Unii mogą wprowadzać zamiast jednego limitu tzw limity sektorowe; np. Francja ma odrębny limit na sprzedaż towarów i inny na sprzedaż usług. Przekroczenie któregoś z nich pozbawia SME zwolnienia z VAT w tym kraju. Przekroczenie unijnego limitu 100tys EUR pozbawia SME zwolnienia w każdym kraju Unii.
  • Zaczniemy od nowej opcji "A/1/9/5.Limity w krajach Unii". W opcji tej zobaczymy listę wszystkich krajów Unii z przyporządkowanymi im limitami. Trzeba sprawdzić i ewentualnie poprawić wysokość tych limitów. Teoretycznie na stronach UE (zobacz tu) powinny być aktualne limity. Jeżeli w danym kraju obowiązuje 1 limit, to wystarczy wpisać kwotę w pole z pierwszym sektorem i nie podawać jego nazwy. Jeżeli sektorów jest więcej należy podać nazwę sektora. Następny sektor znajdziemy naciskając klawisz "kursor w prawo" poprzedni "kursor w lewo". Edycja kwoty i nazwy sektora po naciśnięciu klawisza Enter. Tabela z limitami w krajach Unii jest wspólna dla wszystkich firm. Wszystkie kwoty podajemy w EUR. Jeżeli dany kraj zdefiniował swój limit we własnej walucie (np. Polska 200tys PLN) to należy go przeliczyć na EUR wg kursu opublikowanego przez EBC na dzień 1 styczeń każdego roku (lub pierwszy roboczy, jeżeli 1 styczeń jest dniem wolnym)
  • Gdy limity mamy już ustalone, należy poinformować program, w których krajach będziemy prowadzić (lub już prowadzimy) sprzedaż. Rozróżniamy 3 modele prowadzonej sprzedaży:
    • Krajowa - to sprzedaż prowadzona na terenie Polski i Unii, którą musimy ewidencjonować w plikach jpk. Jeżeli podatnik wybrał w Polsce zwolnienie z podatku VAT informację o obrotach będziemy przyjmować na podstawie ewidencji w księdze przychodów i ryczałtowca. Jeżeli nie jest zwolniony to na podstawie plików jpk.
    • OSS - To sprzedaż na rzecz konsumentów w kraju Unijnym. Podatnik prowadzi ją po zarejestrowaniu się w procedurze OSS i odprowadza podatki do każdego kraju swojego konsumenta za pośrednictwem II US w Warszawie składając odpowiednią deklarację VIU-DO. Tę sprzedaż będziemy importować z odpowiednich tabel programu Ksp, w których rejestrujemy odpowiednią ewidencję.
    • Vat - To sprzedaż prowadzona na terenie Unii w krajach, w których podatnik zarejestrował się jako podatnik VAT i odprowadza do tamtejszych urzędów stosowny podatek VAT zgodnie z przepisami tego kraju. Sumę tej sprzedaży trzeba będzie wpisać do Ksp "ręcznie". Posłuży nam do sprawdzania, czy nie przekroczono unijnego limitu 100tys EUR.
    • Sme  To sprzedaż zwolniona z podatku Vat, prowadzona w krajach Unii po zgłoszeniu się do procedury Sme i uzyskaniu właściwego numeru identyfikacyjnego EX. Informację o sprzedaży w tym trybie uzyskamy z odpowiedniej ewidencji prowadzonej w programie Ksp.
  • W opcji "A/1/9/4.Gdzie prowadzę DG" zobaczymy tabelę z listą krajów Unii oraz poszczególnymi kolumnami:
    • Status podatnika względem VAT: Po naciśnięciu klawisza Enter trzeba wybrać spośród następujących opcji:
      • Nie prowadzę działalności gospodarczej: Oznacza to, że na terenie tego kraju podatnik nie jest zarejestrowany do podatku VAT ani nie zarejestrował się w procedurze Sme, wybierając tym samym zwolnienie z tego podatku.
      • Działalność gospodarcza zarejestrowana do Vat. Podatnik zarejestrował działalność VAT w danym kraju i odprowadza tam podatek.
      • Działalność zarejestrowana do SME. Podatnik zarejestrował się do procedury SME, wybierają zwolnienie z podatku VAT w tym kraju. (o ile dany kraj na tę procedurę zezwala).
    • Rejestracja w OSS. W tej kolumnie mamy tylko dwie opcje, albo prowadzimy sprzedaż wysyłkową OSS albo nie. Rejestracja w Sme wyklucza rejestrację w OSS. Bowiem po wybraniu OSS stajemy się podatnikami VAT w danym kraju, tyle że nie musimy się w nim osobiście rejestrować (np. za pośrednictwem przedstawiciela podatkowego)
    • Data Zmiany: Jeżeli przekroczymy limity danego kraju, to nie możemy już korzystać w tym kraju ze zwolnienia jako SME. Należy więc wpisać datę przekroczenia limitu i wybrać opcję albo rejestrujemy się do VAT albo rezygnujemy z prowadzenia DG w tym kraju.
  • Gdy poinformujemy program o krajach i sposobie prowadzenia w nich działalności, możemy przejść do wprowadzania dokumentów sprzedaży (opcja "A/1/9/1.Ewidencja dokumentów Sme"). Podstawowe informacje dla każdego dokumentu to:
    • Data sprzedaży: Data decyduje o okresie, do którego dana sprzedaż zostanie zakwalifikowana oraz o kursie wg którego faktura zostanie przeliczona na PLN celem zaewidencjonowania jej w księdze. Będzie to kurs NBP z dnia poprzedniego względem tej daty.
    • Data wystawienia: Data wystawienia dokumentu.
    • Data Ksp: Data pod którą dokument będzie ujęty w księdze przychodów.
    • Data korekty: Jeżeli będziemy dopisywać dokument korygujący ewidencję (np. zapomniany dokument, zwrot, popraw kwoty itp) to trzeba wpisać tę datę. Pełni podobną funkcję do odpowiedniej daty w ewidencji Vat. ale są pewne różnice. Omówimy je w dalszej części instrukcji.
    • Deklaracja: To numer deklaracji w której ujęta będzie sprzedaż lub jej korekta.
    • Kraj UE: to kraj unii w którym wybraliśmy zwolnienie Sme. Insert pozwoli nam wybrać kraj z listy.
    • Waluta faktury: Trzeba wpisać walutę, w której została dokonana sprzedaż. Ksp przeliczy wprowadzoną kwotę na PLN wg kursu NBP lub wg kursu wprowadzonego przez użytkownika. Można wpisać kurs, lub kwotę w PLN. Jeśli tego nie zrobimy Ksp wykona obliczenie automatycznie. Przeliczenie na wymaganą przez unię walutę EUR odbędzie się wg kursu EBC z 1-go stycznia. Klawisz Insert naciśnięty w polu z kwotą w PLN lub kursem waluty pobierze właściwy kurs i dokona obliczenia kwoty w PLN.
    • Kwota sektor 1,2,3: Wpisujemy kwotę sprzedaży dla poszczególnych sektorów zdefiniowanych w danym kraju. Jeżeli w danym kraju nie zdefiniowano sektorów, kwotę wpisujemy w pierwsze pole.
  • Jeżeli mamy już wpisane dokumenty to możemy przejść do opcji "2.Sprzedaż wg krajów" lub "3.Sprzeda wg miesięcy". Pierwsza pozwala zobaczyć obroty w danym kraju w podziale na Oss,Vat,Sme w wybranym miesiącu. Miesiąc wybieramy klawiszem ALT+M. Można więc zobaczyć w którym kraju zostają przekroczone limity zwolnienia. Druga pokazuje nam wszystkie kraje w wybranym miesiącu i służy nam do sprawdzania czy nie przekroczono limitu Unijnego. W obu opcjach Klawisz F3 pobiera dane o OSS i SME. Dodatkowo w opcji pierwszej po naciśnięciu klawisza ENTER na wybranym kraju, będziemy mieli możliwość wpisania obrotów podatnika w tym kraju o ile podatnik zarejestrował się w tym kraju do VAT i podatek ten opłaca w tym kraju.
  • Deklaracja SME-IK. Niestety deklarację (oraz zgłoszenie do SME) składa się wyłącznie za pośrednictwem "Portalu e-urząd skarbowy". Niestety nie ma tam możliwości zaczytania deklaracji w formacie xml, nie można jej też wysłać z pomocą innej aplikacji (np. bcEdek). Dane trzeba wpisać ręcznie. Formatki dostępne w Ksp pozwalają wpisać na portalu wszystkie niezbędne dane. Dodatkowo w opcji "Sprzedaży wg miesięcy" udostępniliśmy zestawienie (klawisz F5), które powinno być podstawą do złożenia SME-IK. Pozostałe zestawienia pojawią się w kolejnych wersjach. Nie mamy też wydruku stosownej ewidencji SME będącej podstawą do przekazania odpowiedniej zbiorczej kwoty do Ksp. To też w kolejnych wersjach.
  • Sprzedaż Sme jest sprzedażą zwolnioną. W związku z tym, chociaż nie rejestrujemy jej w krajowych ewidencjach, ma ona wpływ na sposób odliczania podatku naliczonego w transakcjach ujmowanych w polskiej deklaracji Vat. Jeżeli więc dany zakup służy nam wyłącznie sprzedaży Sme, to nie ujmujemy go w ewidencji zakupów (lub ujmujemy ze stawką zw  taki dokument nie będzie wykazywany w pliku jpk). Dodatkowo sprzedaż Sme będzie miała wpływ na wielkość współczynnika, o którym mowa w Art.90. Ksp na koniec tego roku lub początek następnego wyliczy odpowiedni współczynnik uwzględniając w nim sprzedaż Sme.

Wersja 25.01.026 (06.04.2025)

  • W opcji "Wszystkie dokumenty" dodano eksport zaznaczonych rekordów do pliku w formacie subiekta (epp)
  • Listę, obecności uzupełniono o kolumnę z podpisem pracownika.
  • Do menu z wyborem absencji dodano uzupełniający zasiłek macierzyński z tytułu urodzenia wcześniaka (100%)

Wersja 25.01.025 (02.04.2025)

  • Zbliża się termin rocznego rozliczenia składki zdrowotnej. Aby to zrobić należy w Ksp na rok 2024 przygotować dane o dochodach, które są podstawą do wyliczenia tej składki. Podatnik dla potrzeb opłacania składki zdrowotnej może prowadzić działalność opodatkowaną w formie ryczałtu i/lub na zasadach ogólnych. W prostych przypadkach, gdy prowadzona działalność opodatkowana jest tylko w jednej formie (ryczałt lub działalność), wskazuje jedną firmę (w danych właściciela), z której będzie opłacał podatek dochodowy, a dochody z pozostałych firm będzie pobierał w opcji "5/2.Przychody z innych firm". W tej głównej firmie oznaczonej w danych właściciela jako główna do naliczania składki zdrowotnej należy przygotować dane do rocznego rozliczenia. W tym celu w opcji "5/1.Osobiste dane podatkowe" po naciśnięciu klawisza F5 wybieramy opcję "Dane do rocznej składki zdrowotnej". Dane można pobrać lub wprowadzić ręcznie. Należy wskazać formę opodatkowania w roku 2025, bo od tego zależy wysokość składki należnej za styczeń 2025, który to miesiąc jest ostatnim miesiącem roku składkowego dla podatników na zasadach ogólnych. Po przygotowaniu danych i ich zapamiętaniu należy przejść do Ksp na rok 2025 i wybrać tę samą firmę, dla której dane przygotowaliśmy w roku 2024. Następnie przechodzimy do opcji "D/7.Eksport do płatnika". Tam po naciśnięciu klawisza F5 wybieramy opcję "J.Przygotuj dane do rocznej składki". Dane można pobrać klawiszem Insert lub wpisać "ręcznie" (w tym przypadku nie trzeba ich przygotowywać w roku 2024). Jeśli dane są przygotowane i zatwierdzone, to przy ich eksporcie do płatnika za miesiąc Kwiecień, zostanie dodatkowo wypełniony blok danych z rocznym rozliczeniem składek.
  • W bardziej złożonych sytuacjach, gdy podatnik prowadzi działalność opodatkowaną w formie ryczałtu i dodatkowo na zasadach ogólnych, powinien mieć dwie główne firmy, z których opłaca podatek: jeden zryczałtowany i drugi liniowy/skala, oraz tylko jedną, z której przekazuje do Zus składkę zdrowotna. W każdej z tych dwóch firm powinien przygotować dane do składki rocznej w osobistych danych podatkowych. W firmie ryczałtowej powinien pobrać dane o przychodach opodatkowanych ryczałtem a w firmie na zasadach ogólnych o dochodach opodatkowanych skalą lub liniowo. W obydwu przypadkach zobaczymy tę samą formatkę. W firmie ryczałtowej wypełnia się blok z ryczałtem a w firmie na zasadach ogólnych drugi blok danych. Po przygotowaniu danych w roku 2024 identycznie jak to opisano wyżej pobieramy przygotowane dane do roku 2025 i przekazujemy je do Zus.
  • Można też rozliczyć składkę bezpośrednio w programie płatnik, o ile podatnik nie ponosił w trakcie roku straty, lub sami nie wykonywaliśmy korekt deklaracji bezpośrednio w płatniku z pominięciem Ksp. W pozostałych przypadkach wyliczenia powinny być identyczne jak w Ksp.
  • Poprawiliśmy wczytywanie danych firmy z archiwum. Przy wczytaniu danych nie były aktualizowane dane o rocznej składce zdrowotnej. Czyli jeśli mieliśmy przygotowane dane o rocznej składce a potem zrobiliśmy archiwum firmy i wczytaliśmy to archiwum, to po wczytaniu dane o przygotowanej składce nie były wypełnione.
  • Poprawiliśmy błąd przy obliczaniu podstawy składki Zus+, przy liczeniu ilości dni prowadzonej działalności. Jeśli podatnik miał zawieszoną działalność przez część roku to program przyjmował zawieszenie do jego końca.

Wersja 25.01.024 (30.03.2025)

  • W opcji ze stypendiami (E/6) dodaliśmy parametr określający, czy przy obliczeniach uwzględniać koszty uzyskania i czy liczyć składkę na ubezpieczenie zdrowotne. W przypadku, gdy stypendysta opłaca składkę zdrowotną, uwzględniliśmy to w przekazywaniu danych do płatnika. W związku z tymi zmianami zmieliliśmy kilka zestawień.
  • W ewidencji zakupów krajowych vat dodaliśmy zestawienie (F5) "Drukuj rekordy + stawki vat". Zestawienie nie jest wymaganą przepisami ewidencją. Stanowi pomocniczy wydruk kontrolny.
  • Przy przekazywaniu faktur wystawionych w Ksp przez biuro rachunkowe do ewidencji klientów biura, poprawiliśmy błąd. Błąd polegał na nie przekazaniu faktury zakupowej, jeśli przed przekazaniem na formatce z parametrami przekazywania zaznaczono, aby faktury nie były przekazywane do ewidencji księgowej biura. Czyli jeżeli biuro nie chciało aby faktury zapisywały się w jego księdze przychodów, to ksp błędnie nie przekazywał wystawionych faktur do ewidencji zakupów w księdze klienta biura, pomimo zaznaczenia, że powinien to robić.
  • Dla osób współpracujących i przebywających na zasiłku macierzyńskim, nie będziemy tworzyć deklaracji RCA z kodem 1240, jak ma to miejsce dla "zwykłego" pracownika.

Wersja 25.01.022 (22.03.2025)

  • Nowa wersja dokumentu elektronicznego Z-3.xml. Opublikowana przez Zus 19 marca 2025.
  • Poprawa edytora treści wyjaśnień ORD-ZU i notatnika. W niektórych przypadkach edytor nie pozwalał się uruchomić.
  • Poprawka w zamykaniu miesiąca u podatnika z kasowym PIT. W niektórych przypadkach program informował o niezaksięgowanych dokumentach w poprzednich miesiącach, nie pozwalając na jego zamknięcie.
  • Poprawa wydruku folio u podatnika z kasowym PIT. Zamiast opisu zdarzenia gospodarczego drukowaliśmy przyczynę umieszczenia dokumentu w folio (np. numer dokumentu zapłaty).

Wersja 25.01.021 (18.03.2025)

  • Poprawiono błąd, który powodował, że w niektórych przypadkach w opcji księgowanie u podatnika z Kasowym-PIT pojawiały się dokumenty z zamkniętych okresów.
  • Zgodnie z opisem deklaracji VAT-9M i VAT-8 udostępnionych przez MF na CRWDE w dniu 28 lutego, deklaracje te oznaczono jako obowiązujące w dniu publikacji, dlatego włączyliśmy je do programu. Jednak rozporządzenie (Dz.U 2025.01.27 poz.131) wprowadzają te deklaracje dopiero w rozliczeniu za miesiąc marzec. Niniejsza wersja poprawia ten błąd.
  • Poprawiono błąd, który czasem pojawiał się podczas wydruku folio dla podatnika rozliczającego się metodą kasowego-PIT.
  • Poprawiono błąd w obliczaniu przychodów u ryczałtowca rozliczającego się metodą kasowego-PIT. Zapłata dokumentu przychodowego w następnych miesiącach po miesiącu wystawienia faktury powodowała, że program pokazywał przychód w miesiącu zapłaty i błędnie przychód w miesiącu wystawienia faktury.
  • Ponieważ z programu aptecznego można wyeksportować zakupy i sprzedaż w formacie CDN optima (xml), uwzględniono to w programie Ksp. Pliki przygotowane przez program apteczny nieznacznie różnią się od dokumentacji Comarchu. Dlatego musieliśmy import w Ksp nieznacznie zmienić. Tak więc jeśli program apteczny przygotuje do BR dane w formacie CDN, należy je wczytać do Ksp w opcji "7/7/2.CDN Firma++".
  • W opcji "E/6.Dotowane stypendia z UE" dodaliśmy możliwość wprowadzenia i wyliczenia zaliczek na podatek. Nie uwzględniamy ich jeszcze w żadnej opcji, w której pokazywane są zaliczki z umów zlecenie. Będziemy to uzupełniać w kolejnych wersjach programu.
  • Poprawiono błąd występujący przy łączeniu firm na ryczałcie. Firma główna po połączeniu firm składowych nie miała stawek ryczałtu dla przychodów.

Wersja 25.01.020 (27.02.2025)

  • Amazon zmienił sposób numerowania faktur, co spowodowało, że Ksp przy imporcie sprzedaży OSS pomijał te faktury. Poprawiliśmy import.

Wersja 25.01.019 (26.02.2025)

  • Do importu faktur w formacie csv dodaliśmy "7/7/A/G/Fakturowo" import faktur z portalu fakturowo z pliku csv. Ponieważ w pliku brakuje stawek podatku vat przyjmujemy, że jest to stawka 23% jeśli w pliku występuje vat lub 0% jeśli nie występuje. Nie importujemy faktur vat-marża.
  • Dodaliśmy nową wersję deklaracji VAT-8 (12), oraz VAT-9M(11). Zmiany są niewielkie.
  • W tabeli z dokumentami sprzedaży i zakupów w księdze, po naciśnięciu klawisza TAB, na zmianę prezentowana będzie kwota w księdze i kwota brutto z faktury.
  • Zaktualizowano tabelę opłat ekologicznych na rok 2025. W tabelach, samochody z normą spalania EURO5 i EURO6 mają te same stawki opłat ekologicznych
  • Windows 11 przy którejś ze swoich ostatnich aktualizacji usunął własny edytor plików rtf (wordpad). Ten edytor był również domyślnym edytorem tych plików w programie Ksp. Wybraliśmy ten format pliku z uwagi na niewielkie objętości tworzonych plików i bezproblemowe przechowywanie ich w bazie Ksp. Jeżeli komuś nie uruchamia się edytor tych plików należy w opcji "8/9.Parametry stanowiska" usunąć zawartość pola, które wskazuje edytor plików rtf. Wówczas do edycji Ksp przyjmie domyślny w systemie windows edytor. Można też podać ścieżkę wraz z nazwą programu, z którego najczęściej korzystamy przy edycji dokumentów tego typu. Program instalacyjny, po wykryciu na komputerze wersji 11 systemu windows, usunie wywołanie wordpada z parametrów stanowiska.

Wersja 25.01.018 (23.02.2025)

  • Do importu faktur w formacie csv dodaliśmy "7/7/A/G/Fakturowo" import faktur z portalu fakturowo z pliku csv. Ponieważ w pliku brakuje stawek podatku vat przyjmujemy, że jest to stawka 23% jeśli w pliku występuje vat lub 0% jeśli nie występuje. Nie importujemy faktur vat-marża.

Wersja 25.01.017 (20.02.2025)

  • Przy definiowaniu własnych składników wynagrodzenia, które są obliczane algorytmem dodaliśmy 4 zmienne związane z wyliczeniem stażu pracy:
    • M_staz(b): W tej zmiennej przechowywany jest staż pracy wyrażony w miesiącach i uwzględniający zatrudnienie w zakładzie pracy, w którym obliczamy wynagrodzenia. Np. liczba 126 oznacza 126 miesięcy.
    • R_staz_(b): W tej zmiennej tak jak powyżej przechowywany jest staż pracy wyrażony w latach. Dla przykładu wyżej (126 miesiecy) będzie to liczba 10,5 czyli 10 i pół roku.
    • M_staz(w): "w" w nawiasie wskazuje, że do stażu pracy w firmie, w której obliczamy płace, dodany zostanie staż pracy w innych zakładach pracy. Ten staż wprowadzamy w kartotece pracownika na formatce nr 6. Staż będzie wyrażony w miesiącach.
    • R_staz(w): jak wyżej, z ta różnicą, że staż pracy będzie wyrażony w latach.
  • Gdybyśmy chcieli wypłacić dodatek stażowy, który jest procentem od płacy zasadniczej pracownika określonej w umowie o pracę (zależnym od stażu pracy), to odpowiedni algorytm mógłby mieć postać:
    • R1=f_wyn(1) :płaca zasadnicza z umowy o pracę
    • R2=r_staz(b) :staz pracy wyrażony w latach. Od dnia zatrudnienia do miesiąca, za który wypłacane jest wynagrodzenie włącznie.
    • R3=iif(r2<25,r2,25)/100 :jeśli staż pracy będzie < 25 lat to dodatek wyniesie 1% za każdy rok pracy ale nie więcej niż 25%
    • Wynik=r1*r3
  • Gdybyśmy chcieli wypłacać dodatek zależny od wynagrodzenia brutto wypłaconego w poprzednim miesiącu, to zmienna R1 powinna wynosić: R1=z_mc(8,1)+z_mc(9,1)
  • Wszystkie zmienne dostępne w definiowaniu składników są wyjaśnione po naciśnięciu klawisza ALT+H na definiowanym algorytmie.
  • Poprawiliśmy wyliczanie korekty z art.91 ust.7a do 7d ustawy o Vat. Program nie wyliczał korekty dla zdarzenia polegającego na zmianie kwalifikacji środka trwałego, który podlegałby korekcie przez 5 lub 10 lat, ale w momencie zakupu przyjęto, że podatek naliczony nie podlega odliczeniu wcale lub odliczono go w całości, a obecnie powinien być w pozostałym okresie korekty (5 lub 10 lat), korygowany bieżącym wskaźnikiem proporcji zakończonego roku. Błąd polegał na tym, że pomijaliśmy w obliczeniach to zdarzenie. Uwzględniany był tylko przypadek, gdy związek ze sprzedażą uległ zmianie z opodatkowanej na wyłącznie zwolnioną lub odwrotnie.
  • Przy imporcie danych w formacie Subiekta (epp) do opcji OSS, poprawiliśmy błąd związany z przeliczaniem forintów na złotówki. Niektóre programy tworzą plik komunikacyjny podając kurs HUF za 100 forintów a inne za jednego. W pliku importowym nie ma znacznika, który mógłby o tym poinformować Ksp. Obecnie będziemy ten fakt "dedukować".
  • Dodaliśmy import faktur z aplikacji "Fakturownia" do modułu OSS.
  • Zaktualizowaliśmy stawki podatku VAT w Słowacji. Obecnie mamy 23%, 19% i 5%
  • Poprawiliśmy błąd związany z tworzeniem pliku jpk dla transakcji przyjęcia zaliczki w procedurze vat-marża udokumentowanej dowodem wewnętrznym lub paragonem. Odpowiedni zapis w xml nie zawierał oznaczenia procedury MR_T.

Wersja 25.01.016 (16.02.2025)

  • W danych płacowych pracownika dodano do menu sposób rozwiązania umowy o pracę na podstawie art.23' KP.
  • Dla podatników rozliczających podatek VAT kasowo, poprawiono aktualizację na podstawie ubiegłego roku dokumentów zakupu paliwa zapłaconych w roku 2025. Kwota netto zakupu wynikała z faktury a nie z proporcji odliczonego podatku vat (była cała zamiast połowy).
  • Poprawa importu z Saldeo dokumentów zakupowych. Po imporcie do Ksp program przyjmował datę wpływu dokumentu, jako datę wykonania importu.
  • Poprawa wydruku folio dla podatnika, który rozlicza się metodą "kasowego-PIT". Program generował błąd dla dokumentów rozliczanych memoriałowo.

Wersja 25.01.015 (13.02.2025)

  • W firmie, która rozlicza podatek metodą "kasowego-PIT" program generował błąd przy próbie zaksięgowania dokumentu (nadania numeru Lp) podczas podglądu danych na dokumencie. Poprawiliśmy.
  • Przy edycji zakupów towarów handlowych ("Z") opcja wyboru dodatkowego kwalifikatora dokumentu związanego z zakupami do marży była niedostępna. Dostępna była tylko dla innych wydatków. Poprawiliśmy.

Wersja 25.01.014 (13.02.2025)

  • Dla podatnika "kasowy-PIT", który nie jest podatnikiem VAT, dodaliśmy możliwość wyboru typu dokumentu zakupowego. Dotychczas domyślnie wpisywał się "Dokument bez Vat", co powodowało, że program uznawał go za rozliczany memoriałowo.
  • W niektórych przypadkach po usunięciu wybranych operatorów, program nie pozwalał się zalogować do programu.

Wersja 25.01.013 (11.02.2025)

  • Zaktualizowaliśmy przeciętne wynagrodzenie w gospodarce narodowej za rok 2024 oraz wynagrodzenie w gospodarce za IV kwartał 2024
  • Zaktualizowaliśmy wzorzec wydruku do wskaźnika podstawowego PFRON. Zapomnieliśmy tego zrobić w poprzedniej wersji.
  • Poprawiliśmy ZUA dla osób zagranicznych ze stałym adresem zagranicznym. Bez adresu zameldowania w Polsce. Obowiązkowe dane adresowe dla takiej osoby: to miejscowość, kod kraju, i kod pocztowy miejscowości (bez kresek).
  • Przy imporcie faktur z Saldeo dla podatnika z "kasowym-PIT", uwzględniliśmy zapłaty, a faktury z terminem płatności przypadającym na następny miesiąc (lub jeszcze bardziej odległym) uznawać będziemy za niezapłacone pomimo ustawienia innej wartości w domyślnych parametrach programu.
  • Poprawiliśmy informację o wczytywanej firmie. W przypadku gdy w bazie istniała już taka firma, program informował o tym fakcie podając jej numer fizyczny (numer folderu z danymi) zamiast numeru logicznego (prezentowanego w menu wyboru firm)
  • Urzędy skarbowe wynalazły przepis (Art.23 ust.1 pkt 31) z którego miałoby wynikać, że ryczałtowe koszty uzyskania z tytułu umowy zlecenie z pakietu mobilności są liczone jako procent kwoty brutto pomniejszonej o składki zus i przychód zwolniony (20euro za dzień pobytu za granicą). Pomimo tego że nie można się z tym zgodzić (wszak obowiązuje przepis art.22 ust.3 i 3a), wprowadziliśmy tę niekorzystną zmianę do programu. Jednocześnie wystąpimy o interpretację.

Wersja 25.01.011 (09.02.2025)

  • W tabelach podatkowych prezentowaliśmy fizyczny nr firmy (numer folderu z danymi firmy), podczas gdy powinien to być numer logiczny (ten, który widzimy w menu wyboru firmy). Poprawiliśmy.
  • Do zestawienia dokumentującego obliczenie podstawowego wskaźnika zatrudnienia osób niepełnosprawnych dodaliśmy kolumny z osobami niepełnosprawnymi w stopniu umiarkowanym i znacznym ze szczególnymi schorzeniami. Tym samym dodaliśmy również informacje o sposobie obliczenia wskaźnika obniżającego podstawowy wskaźnik minimalnego udziału osób niepełnosprawnych w zatrudnieniu ogółem (6%) i dodaliśmy wyliczenie składki na PFRON. Zestawienie dostępne jest w opcji "D/9/6/1.Wskaźnik podstawowy (Art.21)".
  • Do wyliczenia składki PFRON niezbędna jest znajomość przeciętnego miesięcznego wynagrodzenia w gospodarce narodowej. W związku z tym dodaliśmy opcje "D/9/8.Przeciętne wynagrodzenie w danym Kwartale". Wynagrodzenie za IV kwartał 2024 zostanie opublikowane w dniu 11-02-2025. Trzeba je będzie albo wpisać do programu, albo pobrać jego nową wersję.
  • W danych właściciela rozszerzyliśmy pole z numerem domu do 10-ciu znaków.

Wersja 25.01.010 (05.02.2025)

  • Przy instalacji na Nowy Rok oraz przy aktualizacji umów o pracę i zlecenia nie przenosiły się aneksy do umów zlecenie. Poprawiliśmy, a dodatkowo dodaliśmy w aktualizacji opcję "7/8/6.Aktualizuj aneksy do zleceń".
  • W obliczeniach urlopu należnego poprawiliśmy pobieranie danych o etacie i okresie zatrudnienia z nim związanym.
  • W związku z wprowadzenie dodatkowego dnia wolnego (24 grudzień) począwszy od lutego 2025 obowiązuje nowy współczynnik ekwiwalentu (20,75). Wprowadziliśmy go do programu. Dodatkowo zmieniliśmy kalendarz standardowy. Kalendarze niestandardowe i godzinowy trzeba ewentualnie zmodyfikować samemu.
  • Do podsumowania listy płac dodaliśmy brakujące "Sanitariaty" z pakietu mobilności.

Wersja 25.01.009 (28.01.2025)

  • Program instalacyjny poprawi błąd występujący przy tworzeniu IFT-1R. W niektórych umowach z kodem 99 brakowało znacznika artykułu, z którego wynika opodatkowanie ryczałtem. Problem występował, jeśli kod umowy był wpisywany "z ręki" a nie wybierany z menu.
  • Przy obliczaniu wymiaru należnego urlopu wypoczynkowego uwzględniono obniżenia z tytułu urlopu wychowawczego, bezpłatnego.
  • Przy aktualizacji i pobieraniu danych z roku 2024 program informując użytkownika o numerze firmy podawał numer folderu z firmą zamiast jej logiczny numer występujący w menu wyboru firm.

Wersja 25.01.008 (23.01.2025)

  • Poprawa błędu przy tworzeniu Pit-11. Jeśli któryś z pracowników miał ulgę 152..154 to program zaznaczał mu to w pozycji 118..120 i pozostawiał zaznaczenie dla wszystkich następnych pracowników (przy tworzeniu PIT-11 dla wielu pracowników jednocześnie).
  • Zaktualizowaliśmy przeciętne wynagrodzenie wraz nagrodami z zysku za IV kw 2024 (8549,18zł), co ma wpływ na wysokość składek na ub. zdrowotne ryczałtowców i osób współpracujących.

Wersja 25.01.005 (12.01.2025)

  • Zaktualizowaliśmy na naszej stronie w sekcji ftp kalkulator Excel z wyborem formy opodatkowania na rok 2025. Pobierz. Kalkulator wykona poprawne obliczenia, jeżeli wpiszemy wartość przeciętnego wynagrodzenia za IV kwartał 2024 wraz z nagrodami z zysku. Obecnie wartość ta nie jest jeszcze znana i z tego powodu kalkulator nie jest w stanie obliczyć poprawnej wartości składek na ubezpieczenia zdrowotne dla prowadzących DG i opodatkowanych ryczałtem.
  • W wydruku załącznika do umowy o pracę, w części informacji dodatkowych pkt. 10. Zmieniliśmy informację o okresie wypowiedzenia. Wprowadziliśmy daty "od" lub "do" których dany okres wypowiedzenia obowiązuje.
  • W środkach trwałych w opcji "C/1/2.Środki trwałe  przeglądanie" dodaliśmy tworzenie pliku jpk_st.xml dla KpiR i EWP oraz jpk_st_kr.xml dla ksiąg handlowych. Do danych o środku trwałym dodaliśmy informację o numerze dokumentu OT.

Wersja 25.01.004 (09.01.2025)

  • Poprawiliśmy zestawienie urlopów należnych. Wydruk nie mieścił się na drukarce.
  • Poprawiliśmy aktualizację umów zlecenia na podstawie danych z 2024 rok. Program nie pobierał wystawionych rachunków.
  • Zaktualizowaliśmy tabele środków trwałych. Przygotowując się do zmian w roku 2026, uzupełniliśmy w środkach informację o sposób nabycia środka i przyczynę likwidacji. Dotychczas te pola wypełniał użytkownik obecnie, ponieważ nowe struktury jpk_st wymagają w tych polach wartości ze ściśle zdefiniowanego przez MF słownika, musieliśmy te słowniki wprowadzić do programu. A więc wybieramy je po naciśnięciu klawisza Insert.

Wersja 25.01.002 (01.01.2025)

  • Zmieniono wartość minimalnej podstawy składki zdrowotnej na 75% płacy minimalnej.
  • Przy wyliczeniu dochodu, który stanowi podstawę wymiaru składki zdrowotnej nie będziemy uwzględniać przychodów i kosztów związanych ze sprzedażą majątku firmy. Do majątku firmy zaliczamy:
    • środki trwałe albo wartości niematerialne i prawne, podlegające ujęciu w ewidencji środków trwałych oraz wartości niematerialnych i prawnych,
    • składniki majątku, o których mowa w art. 22d ust. 1, z wyłączeniem składników, których wartość początkowa ustalona zgodnie z art. 22g nie przekracza 1500 zł,
    • składniki majątku, które ze względu na przewidywany okres używania równy lub krótszy niż rok nie zostały zaliczone do środków trwałych albo wartości niematerialnych i prawnych,
    • składniki majątku stanowiące spółdzielcze prawo do lokalu użytkowego lub udział w takim prawie, które zgodnie z art. 22n ust. 3 nie podlegają ujęciu w ewidencji środków trwałych oraz wartości niematerialnych i prawnych
  • Jak z tego wynika, przy sprzedaży majątku firmy należy zwrócić uwagę nie tylko na te środki, które zostały ujęte w ewidencji, ale również np. na wyposażenie, czy środki zaliczone bezpośrednio w koszty. W Ksp, jeżeli sprzedaż ujęta jest w pozycji "pozostałe przychody", po akceptacji dokumentu, pokaże się nam formatka, na której wpiszemy kwotę przychodu ze zbycia majątku (klawisz Insert podpowie nam kwotę z pola "pozostałe przychody"). Wpisana kwota przychodu zmniejszy podstawę składki zdrowotnej. Dodatkowo należy wpisać kwotę odpisu nieplanowego (wartość netto sprzedanego środka) związanego ze sprzedażą środka trwałego lub WNiP. Wartość ta powiększy dochód stanowiący podstawę składki zdrowotnej.
  • Jeżeli podatnik opodatkowany jest ryczałem, na dokumentach sprzedaży pojawi się dodatkowe pole z pytaniem, czy sprzedaż dotyczy składników majątku. Twierdząca odpowiedź udostępni nam formatkę, na której należy wpisać kwotę sprzedaży środka. Kwota ta pomniejszy obrót firmy, który porównywany jest z progami zgodnie z którymi opłacamy składkę zdrowotną.
  • W przychodach z innych firm ryczałtowych wprowadzono informację o sprzedaży składników majątku firmy. Dla podatników na skali lub podatku liniowym takie formatki już istniały. Obecnie zmieniono jedynie opisy poszczególnych kwot.
  • Od 2025 podatnik, o ile spełnia pewne warunki, może wybrać kasowy sposób rozliczania podatku dochodowego; nazwiemy go "kasowcem". Ponieważ kasowiec oprócz nowego sposobu ewidencjonowania dokumentów, część z nich musi ewidencjonować starym sposobem (memoriałowo), więc jego księgowość znacznie się komplikuje.
  • Pod pojęciem faktury kasowej będziemy rozumieć fakturę spełniającą wszystkie wymagania jakie stawia przed dokumentem ustawa o VAT zarówno w stosunku do terminów jej wystawienia jak i zawartości, spełniającą łącznie następujące warunki:
    • Dokumentuje transakcję B2B. A więc z podatnikiem prowadzącym działalność i posiadającym numer NIP lub TIN. Uwaga: w ksp jedynie transakcje z kontrahentem pobranym z kartoteki kontrahentów i posiadającym numer NIP lub TIN będą uznane za transakcje rozliczane kasowo.
    • Kontrahent nie może być powiązany z podatnikiem, nie może być podmiotem publicznym ani mieć siedziby w rajach podatkowych. Do kartoteki kontrahentów dodaliśmy informację bardziej ogólną. Wpisujemy Tak jeśli transakcje z kontrahentem mają być w każdym przypadku rozliczane memoriałowo. Odpowiedni opis do pola ma treść: "w metodzie kasowej PIT rozliczaj memoriałowo". Oczywiście jeśli kontrahent z innego powodu nie jest rozliczany kasowo, pole można pozostawić puste. (np. kontrahent jest konsumentem i nie posiada numeru NIP - transakcje B2C)
    • Faktura nie może dokumentować sprzedaży środka trwałego (ŚT) lub wartości niematerialnej i prawnej (WNiP) ujętej w ewidencji i podlegającej amortyzacji. Należy zwrócić uwagę na pewną rozbieżność związaną z podstawą rozliczenia składki zdrowotnej. Tam w podstawie nie uwzględniamy sprzedaży dowolnej części majątku. W podatku dochodowym tylko tego majątku, który jest ŚT ujętym w ewidencji lub WNiP. A wiec kasowo rozliczymy sprzedaż wyposażenia i środków, które zostały bezpośrednio zaliczone w koszty (bez amortyzacji). W związku z tym na formatkach dotyczących sprzedaży dodaliśmy specjalne pola, w które należy wpisać odpowiedź Tak lub Nie na następujące pytanie: "Czy sprzedajemy Środek Trwały lub WNiP podlegającą amortyzacji?".
    • Faktura dokumentuje przyjęcie zaliczki. Tak więc, jeśli taka faktura spełnia powyższe warunki, to wpisujemy ją do Ksp jak każdą inną, zwykłą fakturę. Jeżeli nie spełnia powyższych warunków, wpisujemy ją do ewidencji zaliczek (jak w metodzie memoriałowej).
  • Podsumowując: rozliczając przychody kasowca będziemy mieli do czynienia z przychodami kasowymi i memoriałowymi wyliczmy je. Złóżmy że bieżący rok to 2030 i podatnik wybrał w nim metodę kasowego PIT
  • Uwaga: Każdy dokument będzie wpisywany do Ksp tak jak dotychczas. Ten wpis nazwiemy memoriałowym. O tym czy memoriałowy wpis zostanie potraktowany kasowo będzie zależeć czy wpis ten udokumentowany jest fakturą kasową. Jeśli tak, dodatkowo zostaną zbadane przez program zapłaty dokumentu.
Przychody rozliczane memoriałowo:
  • Sprzedaż B2C - na rzecz konsumenta - osoby fizycznej nie prowadzącej działalności gospodarczej
  • B2P - Sprzedaż dla podmiotu publicznego (np. NFZ)
  • Faktura dokumentująca sprzedaż ŚT lub WNiP
  • Faktura dla podmiotu powiązanego
  • Faktura dla podmiotu z raju podatkowego
  • Sprzedaż udokumentowana innym dokumentem niż faktura lub faktura do paragonu
Przychody rozliczane kasowo:
  • Zapłata faktury kasowej wystawionej w roku 2030, 2029, 2028 ale przed upływem 2 lat od dnia jej wystawienia
  • Przyjęcie zaliczki udokumentowanej fakturą kasową w roku 2030
  • Niezapłacona część faktury kasowej w dniu, w którym upływa 2 lata od dnia wystawienia faktury
  • Niezapłacona część faktury kasowej w dniu likwidacji działalności
  • Sprzedaż wyposażenia i środków trwałych udokumentowana fakturą kasową i zaliczonych przy zakupie bezpośrednio w koszty (nie amortyzowane)
  • Uwaga1: Zmiana formy opodatkowania w roku 2031 nie wpływa na sposób rozliczania przychodów kasowych. również zmiana na ryczałt.
  • Uwaga2: Rezygnacja z metody kasowej w roku 2031 nie wpływa na kasowe rozliczanie przychodów kasowych z lat 2030, 2029
Koszty rozliczane kasowo:
  • Zakupy z lat 2030, 2029...2025 udokumentowane fakturą kasową w dniu jej zapłaty, ale nie wcześniej niż w dacie poniesienia kosztu (np. otrzymania faktury) bez znaczenia, czy w dniu zapłaty podatnik jest kasowy czy nie. Warunek - podatnik nie zmienił formy opodatkowania na ryczałt.
  • Jeżeli w roku 2031 zmieniono formę opodatkowania na ryczałt, to zapłaty do faktur z lat 2025...2029, 2030 będą korygować zeznanie za rok 2030.
  • Gdy zlikwidujemy działalność faktury kasowe uważa się za zapłacone w dniu likwidacji
  • Zapłata zaliczki udokumentowanej fakturą kasową (nie wcześniej niż data wystawienia faktury)
  • Uwaga: Fakturą kasową w zakupach będzie również faktura otrzymana od podmiotu powiązanego i podmiotu z siedzibą w raju podatkowym.
Koszty rozliczane memoriałowo:
  • Wszystkie faktury, które nie są rozliczne kasowo, są rozliczne memoriałowo.
Remanent
  • W spisie z natury dokonywanym w roku, w którym podatnik jest kasowcem będziemy uwzględniać wyłącznie wartości tych towarów, których zakup został opłacony do dnia sporządzenia remanentu włącznie. Tak więc spis ilościowy obejmuje wszystkie towary, a spis wartościowy jedynie te zapłacone. Tu pojawia się pewien problem. Jeżeli w roku 2030 podatnik jest kasowcem i na koniec roku sporządzi remanent, którego wartość będzie określona wyłącznie przez zapłacone towary, to jaką wartość początkową i końcową remanentów wykaże podatnik w roku 2031 jeśli w tym roku zrezygnuje z metody kasowej?. Otóż niestety, ale aż do "przejścia na emeryturę" będzie musiał w remanentach wykazać tylko zapłacone towary o ile zostały kupione w okresie, gdy był kasowcem. To samo dotyczy kasowej ewidencji zakupów, trzeba ją będzie prowadzić aż do emerytury chyba, że w którymś z lat podatnik wybierze ryczałt, wtedy wszystkie niezapłacone zakupy a więc również remanent staną się zapłacone i problem się rozwiąże. Trzeba się więc dobrze zastanowić czy warto skorzystać z tej nowej metody rozliczeń.
  • W Ksp w opcji z remanentem będziemy mieli jak dotychczas kolumnę tabeli z wartością remanentu. Wartość ta będzie uczestniczyć w obliczeniach dochodu firmy (tak jak dotychczas). Należy więc w tę kolumnę wpisywać remanent dotyczący wyłącznie zapłaconych towarów jeśli zostały kupione w latach w których podatnik był kasowcem i towarów bez względu na stan ich zapłaty jeśli zostały zakupione w latach, gdy podatnik stosował metodę memoriałową. Dla celów informacyjnych dodaliśmy kolumnę z wartością towarów niezapłaconych i kolumnę "razem" w której będzie suma dwóch poprzednich kolumn a więc memoriałowa wartość remanentu.
Jak obliczany będzie dochód?
  • W pierwszej kolejności zostanie obliczony przychód (P_M(i)) i koszty (K_M(i)) tak jak dotychczas metodą memoriałową. Załóżmy, że bieżącym rokiem jest 2030, a obliczanym miesiącem maj 2030. Będą to więc przychody i koszty memoriałowe za miesiące i=1..5. Będzie na ten fakt wskazywać literka M.
  • Przez "memoriałowo", będziemy rozumieć zaewidencjonowanie w księdze dokumentu (tak jak dotychczas), bez względu na stan zapłaty dokumentu.
  • Następnie obliczymy przychody (P_Kn(i)) oraz koszty kasowe (K_Kn(i)) za miesiące 1..5 które nie zostały zapłacone (lub częściowo niezapłacone) w danym miesiącu. Np. jeśli faktura dokumentuje zakup kasowy w miesiącu 3 a zakup ten został zapłacony w miesiącu 4 to niezapłacona kwota zostanie ujęta w zmiennej K_Kn(3).
  • Następnie obliczymy kwotę kosztów kasowych, które memoriałowo zostały ujęte w roku 2030 lub wszystkich latach poprzednich, w których podatnik był kasowcem i które zostały zapłacone w miesiącu "i". Tę kwotę oznaczymy K_Kz(i). Cofając się wstecz w celu ustalenia, który dokument został zapłacony w miesiącu "i", będziemy to robić aż do roku następującego po roku w którym podatnik wybrał ryczałt. Oczywiście nie wcześniej niż rok 2025.
  • Podobnie dla przychodów ustalimy kwotę P_Kz(i). Czyli kwotę zapłaconego w miesiącu "i" przychodu, który memoriałowo został ujęty w miesiącu i roku, w którym podatnik był kasowcem. Będziemy brali pod uwagę jedynie te dokumenty, dla których od dnia memoriałowego ujęcia w księdze do rozpatrywanego miesiąca nie upłynęło 2 lata. Dla dokumentów, którym w miesiącu "i" upływa 2 lata od daty ujęcia memoriałowo w księdze w miesiącu "i", przyjmiemy, że w miesiącu "i" dokument zostaje opłacony, a więc powiększy wartość zmiennej P_K2(i).
Podsumujmy:
P_M(i) | : | Przychód memoriałowy w miesiącu "i"
P_Kn(i) | : | Kwota niezapłaconych przychodów kasowych memoriałowo ujętych w miesiącu "i"
P_Kz(i) | : | Kwota zapłaconych w miesiącu "i" faktur z dwóch lat poprzedzających miesiąc "i". Uwzględniamy tylko rok bieżący i lata poprzednie, w których podatnik był kasowcem.
P_K2(i) | : | Wartość niezapłaconych faktur z okresu, w którym podatnik był kasowcem, którym w miesiącu "i" mija okres 2 lat ujęcia dokumentu memoriałowo w księdze.
P_K(i) | : | Łącznym kasowym przychodem w miesiącu "i" będzie P_K(i)=P_M(i)  P_Kn(i) + P_Kz(i) + P_K2(i)
K_M(i) | : | koszty wpisane memoriałowo w miesiącu "i"
K_Kn(i) | : | Kwota niezapłaconych kasowych kosztów w miesiącu "i" ujętych memoriałowo w miesiącu "i"
K_Kz(i) | : | Kwota zapłaconych w miesiącu "i" kasowych faktur zakupowych ujętych memoriałowo w poprzednich miesiącach i latach.
K_K(i) | : | Koszty kasowe w miesiącu "i" będą równe K_K(i)=K_M(i)-K_Kn(i)+K_Kz(i).
  • W ostatniej kolejności obliczamy sumę przychodów kasowych SPK(i) oraz sumę kosztów kasowych SKK(i) za miesiące od stycznia do miesiąca "i".
  • Dochodem/stratą kasową za miesiące od stycznia do miesiąca "i" będzie różnica SPK(i)  SKKi  (Rp  Rk(i)). Rp jest kasowym remanentem początkowym na 1 stycznia 2030, a Rk(i) jest kasowym remanentem sporządzonym w miesiącu "i". Jeśli remanent w miesiącu "i" nie będzie sporządzony to przyjmiemy, że wartością Rk(i) jest ostatnio sporządzony remanent.

Podstawa ubezpieczenia zdrowotnego w metodzie kasowej:

  • Od ustalonego dochodu kasowego należy odjąć:
    • Sprzedaż ŚT i WniP z roku 2030
    • Sprzedaż wyposażenia ujętą memoriałowo, lub ujętą kasowo w części zapłaconej w roku 2030
    • Sprzedaż pozostałego majątku ujętą memoriałowo, lub ujętą kasowo w części zapłaconej w 2030 roku
  • Do ustalonego dochodu kasowego należy dodać
    • Odpis nieplanowy od Sprzedaży ŚT i WniP
  • Jak z tego wynika przy sprzedaży majątku firmy w metodzie kasowej musimy wiedzieć czy majątek jest ŚT lub WNiP, czy też sprzedaż dotyczy pozostałego majątku. ŚT i WNiP są ujmowane w księdze memoriałowo, więc wystarczy je odjąć o dochodu, natomiast pozostały majątek ujmowany jest w księdze kasowo w zależności od stanu zapłaty. Trzeba więc odjąć tylko ten majątek, który został zapłacony.

Jak to będzie wyglądać w programie.

  • Staraliśmy się tak zorganizować algorytmy w programie, aby użytkownik w jak najmniejszym stopniu odczuł całkowitą odrębność metody kasowej od dotychczasowej funkcjonalności programu. A więc aby tak jak dotychczas prowadził ewidencje, rejestrował dokumenty i drukował deklaracje. Oczywiście będą pewne różnice, ale staraliśmy się ograniczyć je do minimum. Dotychczas przychodem firmy w danym miesiącu były zaewidencjonowane w księdze dokumenty przychodowe. Ponieważ w metodzie kasowej wliczamy jedynie faktury opłacone (oczywiście  faktury kasowe), więc dotychczasowy przychód należy zmniejszyć o faktury niezapłacone (wcześniej zapłata faktury nie miała żadnego znaczenia). Z drugiej strony, jeśli jakaś faktura nie była wcześniej ujęta w przychodach a w danym miesiącu została zapłacona to przychód tego miesiąca należy powiększyć o dokonaną zapłatę. Podobnie jest z kosztami. Gdyby wszystkie faktury rozliczane były kasowo, wtedy warto byłoby napisać odrębny moduł kasowego PIT. Jednak tak nie jest. Podatnik będzie miał faktury i inne dokumenty rozliczane tak jak dotychczas (memoriałowo) a dodatkowo faktury kasowe rozliczane na innych zasadach i do tego wystawione niekoniecznie w danym roku podatkowym, ale we wszystkich poprzednich latach, w których podatnik wybierał metodę kasową. O szczegółach napisaliśmy wyżej.
  • Jeżeli podatnik prowadzi jednoosobową działalność gospodarczą i wybierze metodę kasową, w pierwszej kolejności powinien w opcji "8/1/4.Metoda kasowa  lista okresów" zaznaczyć czy w bieżącym roku stosuje metodę kasową i dodatkowo, w których wcześniejszych latach tę metodę stosował. W opcji tej poinformuje program o dacie likwidacji działalności, oraz o zamiarze stosowania opodatkowania ryczałtem przychodów w roku następnym. W obu przypadkach zaewidencjonowane koszty kasowe staną się memoriałowymi w dniu likwidacji działalności lub 31 grudnia (jeśli wybierze w roku następnym ryczałt). Przychody natomiast staną się memoriałowymi w dniu likwidacji działalności. A w przypadku wybrania ryczałtu będą dalej rozliczne kasowo. Dopiero z dniem upływu 2 lat od daty wystawienia faktury staną się przychodami memoriałowymi i od tej daty będą mogły być zaliczone do złych długów.
  • Po zaznaczeniu wyboru metody kasowej, w którymkolwiek z lat program będzie stosował algorytmy metody kasowej. Na czym to polega?
    • Po pierwsze trzeba zdefiniować w jakich okolicznościach program uzna fakturę za kasową. Aby tak się stało faktura musi spełniać następujące warunki:
      • Musi być fakturą, fakturą do paragonu lub fakturą rozliczaną w ewidencji VAT kasowo (F,A,X)
      • Musi być wystawiona dla podatnika, który zostanie wybrany z ewidencji kontrahentów.
      • Kontrahent w ewidencji powinien mieć numer NIP, oraz nie powinien być oznaczony, jako podmiot rozliczany memoriałowo.
    • Jeżeli faktura nie spełnia powyższych warunków zostanie uznana za "zwykłą" fakturę, którą program rozliczy memoriałowo.
    • Faktura uznana za kasową, zostanie uwzględniona w przychodach w następujących sytuacjach:
      • Przy wprowadzeniu faktury zaznaczymy, że została zapłacona (stan=1). W tej sytuacji Ksp nie przekaże jej do opcji "2/(7)8. Zapłaty dokumentów..." i faktura stanie się przychodem (kosztem) w dacie dokonania sprzedaży (wpływu - w zakupach) tak jak faktura memoriałowa. Jedyna różnica polega na umieszczeniu faktury w dodatkowej ewidencji Kasowego-PIT.
      • Jeżeli przy wprowadzeniu dokumentu zaznaczymy, że faktura nie została zapłacona (stan=0), program przekaże dokument do opcji zapłat (2/7 lub 2/8) i taka faktura powiększy przychód lub koszty dopiero w dniu zarejestrowania zapłaty, a w przypadku faktury przychodowej również w dniu, w którym upływa 2 lata od jej wystawienia i w dniu tym nie została zapłacona w całości (lub w dniu likwidacji działalności). Jak z tego wynika oprócz rejestracji faktur kasowych musimy jeszcze kontrolować zapłaty tych dokumentów. Podatnicy którzy korzystali ze złych długów, taką kontrolę i ewidencję zapłat stosowali już dotychczas. Tak więc dla nich nie pojawią się tu żadne nowe czynności.
      • Jeżeli wprowadzając dokument zaznaczymy częściową zapłatę, i na dalszych formatkach wpiszemy ją do programu. Program uzna, że ta zapłata jest przychodem w dniu, który podamy za datę częściowej zapłaty i w przypadku nie wypełnienia pola z numerem dowodu zapłaty, Ksp wpisze, że dowodem jest adnotacja na fakturze.
    • Faktury kasowe zarejestrowane w programie muszą pojawić się w księdze przychodów (ewidencji ryczałtowca) w miesiącu ich zapłaty a nie w miesiącu, w którym zostały wpisane do programu. Jeżeli faktura będzie płacona w kilku ratach, to w księdze pojawi się kilkukrotnie. Za każdym razem otrzymując inny numer ewidencyjny. To spora komplikacja dla algorytmów. Użytkownik nie będzie musiał jednak tego kontrolować. W opcji z "księgowaniem" zobaczy wszystkie zapłaty faktur kasowych (z bieżącego i ubiegłych lat) i nada im kolejne numery ewidencyjne.
    • Pewien dodatkowy problem pojawi się w następnych latach w odniesieniu do faktur przychodowych. Otóż jeśli mamy niezapłaconą fakturę z roku 2025 w którym to roku wybraliśmy podatek liniowy lub skalę, i faktura zostanie zapłacona w roku 2026 w którym wybierzemy ryczałt, to zabraknie nam informacji, wg jakich stawek ryczałtu należy daną zapłatę zaewidencjonować w ewidencji ryczałtowca. Ksp w tej sytuacji poinformuje użytkownika o braku informacji o stawkach ryczałtu i wówczas trzeba będzie poddać edycji odpowiedni dokument w ewidencji zapłat i przypisać kwoty faktury do odpowiednich stawek ryczałtu. Nie można było tego zrobić w roku 2025, bo w roku tym nie wiedzieliśmy jeszcze, że w którymś z następnych lat podatnik wybierze ryczałt.
    • Na dokumencie w ewidencji zapłat dodaliśmy informację, że faktura jest lub nie jest fakturą kasową, oraz jeśli w bieżącym roku wybrany jest ryczałt, to mamy specjalną formatkę do podania stawek ryczałtu.
  • Na tym w zasadzie kończą się zmiany, o których powinien wiedzieć użytkownik. Może jeszcze jedna uwaga. Specjalną ewidencję faktur kasowych możemy wydrukować w opcji, w której drukujemy folio na końcu menu z wyborem jego rodzaju (pod jpk_ewp lub jpk_kpir)
  • Zaliczki. Jeżeli ewidencjonujemy zaliczki rozliczane kasowo, to należy je wpisać bezpośrednio do opcji z przychodami lub zakupami. Zaliczki rozliczane memoriałowo wpisujemy jak dotychczas.