Ostatnie zmiany

(c) Logotech AA

Wersja 26.01.032 (16.04.2026)

  • W opcji "F/7.Import pracowników" dodano pytanie przed wskazaniem pliku, czy import będzie dotyczył pracowników wcześniej wyeksportowanych z Ksp, czy też będą to pracownicy wyeksportowani z programu Płatnik Zus.
  • Podczas instalacji oraz przy wczytywaniu faktur ustrukturyzowanych z KSeF, Ksp będzie poprawiać dane w buforze jeśli faktura będzie błędnie wystawiona i w normalnym trybie nie było możliwości przekazania jej do ewidencji.
  • Faktura dla nabywcy krajowego z krajowymi stawkami VAT, która w podsumowaniu faktury będzie miała wpisany eksport usług lub eksport towarów do kraju unii lub poza unię zostanie przez KSP zmieniona na fakturę krajową z poprawną stopką i przy księgowaniu zostanie przekazana do krajowej sprzedaży.
  • Faktury krajowe bez podsumowania stawek VAT zostaną uzupełnione przez KSP o to podsumowanie zgodnie z pozycjami faktury.
  • Faktury sprzedaży dla nabywcy spoza kraju bez stopki z podsumowaniem sprzedaży zostaną w zależności od dekretu pozycji zaliczone jako eksport usług do unii (jeśli nabywca będzie miał poprawny unijny NIP, lub jako eksport usług poza unię w pozostałych przypadkach. Dokument po zaksięgowaniu będzie można poprawić w ewidencji.
  • Faktury dla krajowego nabywcy z wypełnioną stopką faktury wskazującą na sprzedaż OSS zostaną zaliczone do sprzedaży krajowej.
  • Faktury zakupowe które nie posiadają stopki faktury z podsumowaniem sprzedaży wg stawek VAT, zostaną uzupełnione o stopkę na podstawie pozycji faktury.
  • Dotychczas w podglądzie faktury prezentowaliśmy stawki VAT 0% jako "0%", obecnie będziemy je prezentować tak jak ma to miejsce w fakturze ustrukturyzowanej, a więc:
    • "0 KR": stawka krajowa 0% (pole 13 deklaracji)
    • "0 WDT": stawka 0% stosowana w dostawie towarów do Unii (pole 21 deklaracji)
    • "0 EX": stawka 0% stosowana przy eksporcie towarów poza Unię (pole 22 deklaracji)
    • "np I": stawka odwrotnego obciążenia stosowana zwykle w eksporcie usług poza kraje Unii. Sprzedaż wykazywana jest w polu 11 deklaracji VAT.
    • "np II": stawka odwrotnego obciążenia stosowana w eksporcie usług do Unii. Ta sprzedaż wykazywana jest w polu 12 deklaracji VAT i w deklaracji podsumowującej VAT-UE.
  • W opcji wszystkie "H/3.Wszystkie faktury - korekta" zrezygnowaliśmy z przekazywania faktur wysłanych do KSeF do ewidencji Ksp i Vat. Obecnie tak jak robiliśmy to wcześniej będzie można przekazać faktury, które zostały wysłane do KSeF do opcji "H/2.Księgowanie faktur. Z opcji księgowania będzie je można przekazać do ewidencji klienta i biura i dodatkowo tak jak wcześniej oznaczyć faktury jako przekazane do ewidencji (po oznaczeniu znikną z księgowania). Tak więc w ogólności, faktury przekazane do KSeF będą się zachowywać identycznie jak faktury wystawione poza KSeF.
  • Dotychczas faktury VAT-marża, jeśli nie dotyczyły turystyki, klasyfikowane były automatycznie jako sprzedaż w procedurze uproszczonej zgodnie z art.120 ust.5, jeśli z faktury wynikało, że jest to sprzedaż artykułów kolekcjonerskich, dzieł sztuki lub złota (art.120 ust. 3 i 4). Tego faktu nie dało się zmienić. Obecnie jeśli z faktury wynika, że mamy do czynienia ze sprzedażą w procedurze marży z art.120 ust. 2,3,4 to z automatu przyjmujemy, że jest to sprzedaż towarów używanych, którą ewidencjonuje się w ksp w opcji "2/1/3.Marża towary/turystyka". Jeżeli podatnik w opcjach "A/6.Parametry instalacyjne" wprowadził informację, że ma możliwość stosowania procedury uproszczonej, to na pierwszej formatce bufora sprzedaży KSeF, będzie mógł zmienić procedurę na uproszczoną lub z uproszczonej na zwykłą, po kliknięciu myszą w wiersz z opisem procedury. Faktury marży łącznej przekazujemy do KSP tak jak inne faktury sprzedaży. Natomiast faktury dotyczące marży lub turystyki prostej należy pobrać w opcji "2/1/3.Marża towary/turystyka" edytując dokument i naciskając klawisz Insert w polu z numerem dokumentu. Identycznie postępujemy w turystyce złożonej.

Wersja 26.01.030 (12.04.2026)

  • Faktury wystawione przez Biuro Rachunkowe i przekazane do KSeF można przekazać do Księgi biura i do rozrachunków oraz do księgi i Vat klienta biura w opcji "księgowanie", a więc w miejscu gdzie są przekazywane do KSeF. Jednak po wyjściu z tej opcji znikają i nie są już dostępne w opcji księgowania, tak więc jeśli nie zostały przekazane zaraz po wysłaniu ich do KSeF nie było możliwości przekazania ich do księgi (oczywiście taka możliwość istnieje zawsze przez pobranie ich z KSeF do bufora sprzedaży). Dodatkowo faktur z nadanym numerem KSeF nie można ponownie przekazać do opcji księgowania. Z tego powodu w opcji "Wszystkie faktury" dodaliśmy możliwość przekazania faktur do księgi (o ile zostały zaznaczone). Należy wybrać opcję (F5) "7.Przekaż ponownie do księgowania/Ksp". Faktury zaznaczone które nie mają numeru Ksef zostaną przekazane do opcji Księgowania, natomiast Faktury z numerem KSeF zostaną przekazane do ewidencji w Ksp, tak jak ma to miejsce w przypadku faktur bez numeru KSeF w opcji Księgowania.
  • Poprawiono import zakupów z pliku epp subiekta. Nie importowały się numery KSeF.
  • Otrzymaliśmy przykłady faktur KSeF, dotyczących w całości sprzedaży zwolnionej (np. z art.113), które nie zawierają podsumowania faktury w rozbiciu na stawki. (Formalnie nie ma możliwości wystawienia takiej faktury na portalu KSeF). Przy imporcie do bufora zarówno sprzedaży jak i zakupów uwzględniliśmy te odstępstwa od normy.
  • Identycznie jak w buforze zakupów KSeF, dodano w buforze sprzedaży możliwość zapisania faktur w formacie excel i csv bez pozycji faktury.
  • W informacji podatkowej ryczałtowca przy wydruku folio dodaliśmy pytanie o format wydruku ewidencji. Można obecnie wydrukować ewidencję w poprzednio obowiązującym formacie lub nowy format z numerem KSeF i nipem kontrahenta.
  • Wiele osób pyta nas jak wczytać Z-3 w formacie xml do nowego portalu Zus. Najprościej z głównego menu wybrać opcję "Sprawy płatnika". Następnie "Nowa sprawa", potem "Zaimportuj XML" i na koniec, gdy pojawi się formatka z metodą importu należy wybrać "Import zwykły dokumentów" i w dalszej kolejności wskazać przygotowany plik Z-3 przez Ksp.
  • Uwzględniono przypadek sprzedaży usług do kraju UNII dla podatnika, który nie podał identyfikatora VAT. Taki przypadek nie pozwalał się przekazać do księgi i do Vatu.
  • Poprawiono błąd. Przy przekazywaniu zaliczek z bufora sprzedaży KSeF, faktury przekazywane były również do przychodów w księdze.
  • Przy przekazywaniu faktur rozliczających zaliczki w buforze zakupów, uwzględniono błędną strukturę ustrukturyzowanej faktury. Formalnie zgodnie z opisem Faktura rozliczająca zaliczkę powinna zawierać pozycje zamówienia. W stopce powinny być wymienione kwoty wpłaconych zaliczek oraz rozliczenie ostatniej kwoty do zapłaty/zwrotu wg stawek podatku. Niektóre programy umieszczają kwoty wpłaconych zaliczek z minusami w części z pozycjami zamówienia, co powoduje, że cała część z zamówieniem jest niepoprawna i tak była księgowana w zakupach w księdze. Obecnie uwzględniliśmy takie przypadki i nie księgujemy ujemnych kwot z zamówienia.
  • Otrzymaliśmy wiele przykładów błędnie wystawionych faktur przez podatników, którzy nie są podatnikami vat (powinni wystawiając fakturę zaznaczyć, że są zwolnieni - w fakturze ustrukturyzowanej jest odpowiedni znacznik). Mogą też wszystkie pozycje wystawić w stawce ZW, jednak często wybierają stawkę podatku NP I lub NP. II, Powoduje to, że faktura oznaczana jest w KseF jako eksport towarów lub usług, ale z uwagi na występujący na fakturze poprawny numer NIP polskiego nabywcy, takiej faktury nie dało się w Ksp przekazać do ewidencji. Ksp w takiej sytuacji potraktuje fakturę jako całą zwolnioną z podatku VAT pomimo braku odpowiedniego znacznika w fakturze ustrukturyzowanej i przekaże ją do ewidencji jako zwykłą polską fakturę Vat, pomijając ewidencję VAT. Program instalacyjny odpowiednio zmieni dla takich faktur bufor sprzedaży.
  • Przypominamy, że dla faktur wyrażonych w walucie obcej kwoty dla potrzeb podatku dochodowego przeliczane są wg kursu NBP z dnia poprzedzającego dzień wystawienia faktury (data P_1). Dla tego przed księgowanie faktur należy upewnić się, że w Ksp są pobrane kursy walut.
  • W informacji podatkowej dodaliśmy możliwość wydruku ewidencji ryczałtowca w nowym formacie (z numerem KSeF)
  • Jeżeli data w ewidencji VAT będzie z zakresu 1-30.IV.2026, Ksp przy podpowiadaniu kwoty podatku przy zakupie paliwa założy stawkę 8%.
  • Dokumenty sprzedaży w walucie obcej przekazywane są z bufora sprzedaży KSeF do rozrachunków walutowych celem obliczania różnic kursowych. Rozrachunek jest powiązany z odpowiednim dokumentem w księdze przychodów lub w ewidencji ryczałtowca. Podobnie z zakupami. Różnica jest taka, że rozrachunek zakupowy, nie jest powiązany z żadnym dokumentem w księdze, zachowuje się tak, jakby użytkownik wprowadził go bezpośrednio w rozrachunkach.
  • Przy imporcie faktur z programów sprzedaży, Ksp oprócz zakresu dat, zapyta "Czy importować dokumenty z numerem KSeF?", odrębnie dla sprzedaży i odrębnie dla zakupów. Można więc pominąć import dokumentów, które zostały przekazane do KSeF.
  • W Identyfikator wewnętrzny podmiotu trzeciego składa się z numeru NIP nabywcy, myślnika i pięciocyfrowego identyfikatora np. 6340250615-12345. W opcji "A/7.Lista ID wewnętrzne (KSeF)" można wpisać nadane w firmie identyfikatory (pięć ostatnich cyfr) oraz opis identyfikatora. Przy pobieraniu faktur zakupowych z KSeF, jeżeli któreś z pól faktury ustrukturyzowanej <Podmiot3> będzie miało wpisany identyfikator wewnętrzny o zgodnym numerze NIP z nipem bieżącej firmy, Ksp zapamięta ten identyfikator (5 ostatnich cyfr) i wpisze go do ewidencji zakupów w KPiR. (w fakturze liczba pól <Podmiot3> jest ograniczona do 100. Na razie wykonujemy te operację tylko dla zakupów. Jeśli będzie taka potrzeba dodamy ją również dla sprzedaży.
  • W opcji Zakupy, wydatki oraz wydatki samochodowe naciśniecie klawisza TAB, zmieniało wyświetlaną w kolumnie kwotę netto na kwotę brutto. Obecnie dodatkowo kolumna "GRUPA" zostanie zamieniona na kolumnę "ID wewnętrzne". Będzie więc można przefiltrować tabelę wg wybranego ID.
  • Inaczej we wszystkich dokumentach. Tam dodaliśmy na koniec tabeli kolumnę z ID. Wewnętrznym przypisanym do dokumentu. Naciśnięcie ENTER w tej kolumnie pokaże nam opis identyfikatora, o którym napisaliśmy powyżej. W następnym wersjach będzie rozwijać wykorzystanie identyfikatora wewnętrznego.
  • Na naszej stronie zamieściliśmy tabelkę z datami na podstawie których ujmujemy faktury księgowane z buforów KSeF w ewidencjach KPiR/ryczałtowca i VAT. Dodatkowo tabelka opisuje zasady, na podstawie których przeliczamy faktury z waluty obcej na PLN. Proszę zwrócić uwagę, że w zasadzie nie przeliczamy w ewidencji VAT kwoty podatku, bowiem jest ona wprost wyrażona w złotych na fakturze. Przeliczamy jedynie kwotę netto faktury. Obliczenia realizujemy według innych zasad w Vat i w księdze. Użytkownik zawsze może to poprawić bezpośrednio w ewidencji. Zobacz tabelkę.

Wersja 26.01.028 (26.03.2026)

  • W buforze zakupów KSeF dodano możliwość utworzenia pliku z fakturami w 3 formatach:
    • Format excel w dotychczasowej formie sformatowanej tabeli z opisowym nagłówkiem. Jedna faktura w kilku wierszach zawierająca również pozycje faktury;
    • Format excel w formie tabeli z pojedynczym nagłówkiem. W jednym wierszu jedna faktura. Format przydatny do importowania danych oraz do dalszej obróbki
    • Format csv, przeznaczony do importu danych do innych programów.
  • W buforze zakupów dodaliśmy podsumowanie aktywnych klawiszy funkcyjnych (F1)
  • W buforze zakupów dodaliśmy wyszukiwanie faktury wg fragmentu nr faktury. Wystarczy rozpocząć pisanie numeru od cyfry. Jeżeli będziemy szukać faktury, która w numerze ma wpisany text, to wyszukiwanie należy rozpocząć od wpisania cyfry, następnie można ją usunąć i wpisać tekstową frazę.
  • Dodaliśmy również wyszukiwanie faktury wg fragmentu nazwy kontrahenta. Aby to zrobić należy nacisnąć literkę (z wyjątkiem litery "K", która jest zarezerwowana do księgowania) i wpisać poszukiwaną frazę w nazwie kontrahenta.
  • Aby wyszukać następną fakturę spełniającą wpisane warunki wciskamy klawisz F4.
  • W filtrowaniu (F2) dodaliśmy możliwość odfiltrowania wszystkich faktur kontrahenta, który jest nabywcą w bieżącej fakturze. Jeśli filtr będzie aktywny, pozostałe opcje filtrowania będą go uwzględniać, ale jednocześnie na ostatniej pozycji menu z rodzajem filtra pojawi się możliwość jego usunięcia.
  • Poprawiliśmy błąd, który powodował, że faktury wystawione dla kontrahenta bez numeru NIP, który w miejscu tego numeru miał wpisane słowo "brak", nie wysyłały się do KSeF.

Wersja 26.01.027 (24.03.2026)

  • Dotychczas dla faktur sprzedaży krajowej niezależnie od ustawień, jeśli faktura nie dotyczyła podatników rozliczających się metodą kasową w vat lub podatku dochodowym, Ksp oznaczał fakturę jako zapłaconą. Jak się okazuje lepiej jest, jeśli Ksp działa zgodnie z dekretem zdefiniowanym w buforze sprzedaży KSeF.
  • Zmieniono wygląd zapisu bufora zakupów do pliku excel.
  • Przy klonowaniu faktur wystawianych przez biuro w celu utworzenia nowych na następny miesiąc, Ksp kopiowało do nowych faktur numer KSeF faktur na podstawie których tworzono nowe. Błąd poprawiono. Niestety trzeba je usunąć i wygenerować nowe.
  • Przy klonowaniu dokumentu w wydatkach samochodowych nr ksef faktury klonowanej nie przenosił się do ewidencji zakupów Vat. Program instalacyjny naprawia ten problem.
  • Po publikacjach związanych z ustawianiem typu dokumentu w pliku jpk-vat, wracamy do poprzednich wersji. A więc jeśli użytkownik dla dokumentów zakupów zagranicznych wybierze typ dokumentu "Faktura", to zarówno po stronie podatku naliczonego jak i podatku należnego odpowiedni zapis zostanie oznaczony jako BFK. Gdy użytkownik wybierze rodzaj dokumentu "Dowód wewnętrzny" to odpowiednie oznaczenie w pliku jpk będzie miało wartość DI, zarówno po stronie podatku należnego jak i naliczonego. Po wczytaniu dokumentu jpk do ewidencji w programie bcEdek, od jego dzisiejszej wersji można ewidencję jpk (sprzedaż/zakupy) edytować i w kolumnę typ dokumentu wpisać odpowiednie wartości:
    • 1-OFF
    • 2-BFK
    • 3-DI
  • W ewidencji zakupów dodaliśmy wydruk zaznaczonych dokumentów do csv
  • Poprawiliśmy import faktur leasingowych z Saldeo. Nie importował się nr KSeF w ewidencji zakupów.

Wersja 26.01.026 (22.03.2026)

  • Dla faktur z importem usług lub towarów które generują rekord w sprzedaży w pliku jpk, oznaczaliśmy typ dokumentu jako BFK a powinniśmy go oznaczać jako DI
  • Poprawiliśmy import danych OSS z plików amazon. Zamiast numeru dokumentu wpisywany był kod kraju docelowego.
  • Uzupełniliśmy folio podatnika, który wybrał metodę kasową w podatku dochodowym o numer ksef (odpowiednie pole nie było wypełniane)
  • Przy podglądzie rekordu w ewidencji jpk_vat, (klawisz TAB), gdy dokument nie posiada numeru KSeF pokazujemy typ dokumentu (BFK,OFF,DI)
  • Poprawiliśmy błąd przy pobieraniu danych do rocznej składki zdrowotnej z przygotowanych danych w roku 2025. Przy zmianie formy opodatkowania z liniowej w roku 2025 na skalę w roku 2026 (lub odwrotnie) program przyjmował składkę za styczeń 2026 w wysokości 432.54 zamiast 314.96
  • W rocznym podsumowaniu płac dodaliśmy opcję zapisu podsumowania do pliku csv. Każdy pracownik w odrębnym wierszu. Zestawienie nie uwzględnia wypłat zagranicznych. Tak jak w podsumowaniu na ekran, zestawienie obejmuje sumę należnych składników za rok podatkowy.

Wersja 26.01.024 (17.03.2026)

  • Na podglądzie faktury zakupowej pobranej z KSeF dodaliśmy w podsumowaniu kwotę brutto.
  • Poprawiliśmy księgowanie faktur sprzedażowych dla podatników na ryczałcie. Dla faktur wystawionych dla podatników zagranicznych program często sygnalizował błąd systemowy.
  • Jak co roku można pobrać do rozliczenia składki zdrowotnej, dane przygotowane w roku 2025. Minimalna wersja programu na rok 2025 to 25.01.073. W roku 2025 w ksp w danych osobistych dodaliśmy przygotowanie danych do rozliczenia składki zdrowotnej oraz odpowiedni raport.
  • W buforze zakupowym KSeF dodaliśmy wydruk zestawienia w formacie wydruku (można też zapisać plik do csv). W następnej wersji dodamy odrębne zestawienie w formacie csv.
  • Poprawiliśmy typ dokumentu importowego w jpk_vat na DI. Dotychczas program oznaczał go jako BFK.

Wersja 26.01.023 (07.03.2026)

  • Poprawiono błąd związany z księgowaniem rozliczenia zaliczek w buforze z zakupami, gdy faktura rozliczała zaliczkę do zera (zaliczka równa kwocie całej faktury). W tym przypadku pytamy użytkownika o dekret takiej faktury przed jej zaksięgowaniem. Ponieważ kwota faktury jest zerowa, więc nie widać na ekranie który dekret został wybrany dla faktury. Obecnie można wybrać jedynie jedną z trzech możliwości. Zakupy, Inne wydatki, koszty uboczne. Dla podatnika, który wybrał metodę kasową w podatku dochodowym, jeśli faktura rozliczająca jest zerowa, do księgi nie trafia żaden dokument, jeśli nie jest zerowa do księgi trafia tak jak i do VAT kwota rozliczająca zaliczkę. Dla pozostałych podatników do księgi trafi kwota zamówienia (suma zaliczek plus rozliczenie). Jeżeli na fakturze brak jest podatku naliczonego, taki dokument nie trafia do jpk_vat. (tak jak przed 2026 rokiem).
  • W buforze sprzedaży dodaliśmy przy przeglądaniu dokumentów przekazanych do ewidencji możliwość usunięcia powiązania z ewidencją zaznaczonych dokumentów. Dokumenty na powrót trafiają do dokumentów niezaksięgowanych. Tak jak ma to miejsce w buforze zakupów, jeśli zachodzi taka konieczność trzeba dokumenty usunąć z ewidencji ręcznie.
  • Przy imporcie dokumentów z subiekta (epp) usunęliśmy zawiłą procedurę poprawiania importowanych plików, których struktura odbiegała od dokumentacji Comarchu. W niektórych sytuacjach pliki całkiem poprawne, przestały się poprawnie importować.
  • Dodaliśmy do importu faktur z aptek (Kamsoft), import dokumentów sprzedaży (dotychczas były tylko zakupy) plik importowany ma format "KS-AOW . .xml"

Wersja 26.01.021 (04.03.2026)

  • Wyjaśniamy, że Ksp przekazuje do ewidencji zakupów VAT kwoty netto i vat w całości przyporządkowując je do stawki 23%. Kwoty netto i podatku są poprawne i wynikają ze stopki faktury. Kwota netto nie zawiera kwoty zwolnionej. W przyszłości gdy ogarniemy ważniejsze kwestie to, albo usuniemy stawki VAT z zakupów albo przywrócimy podział kwot na stawki jeżeli okaże się, że jest to przydatne dla celów kontrolnych. Ani na deklaracji VAT ani w części ewidencyjnej JPK_VAT podział na stawki podatku nie występuje.
  • Nie trzeba uzupełniać (a nawet byłoby to poważnym błędem) numeru NIP o przedrostek PL wymagany dla KPiR. Ksp robi to automatycznie, gdy brakuje oznaczenia kraju a numer NIP spełnia formalne wymagania dla tego numeru (9 cyfr + poprawna cyfra kontrolna)
  • Poprawiliśmy błąd. Jeżeli część pozycji została skorygowana np. usunięta z powodu braku związku z DG, Ksp przekazywał do ewidencji Zakupów całą kwotę. W szczególności robił to również dla niewatowców przekazując kwotę do księgi.
  • Jeżeli w buforze zakupów na liście wybieranych zdarzeń gospodarczych brakuje właściwego zdarzenia, to należy nacisnąć Enter i wpisać go w aktywne pole edycyjne. Ksp, jeśli będą istniały zaznaczone dokumenty podstawi opis pod zaznaczone faktury. Dodatkowo bez względu na to czy są zaznaczone czy nie, zapyta czy wprowadzony opis dodać listy opisów wybieranych z menu.
  • Uzupełniliśmy import dokumentów z CDN o import numeru KSeF. W ostatniej wersji CDNa dodano odpowiednie pole z tym numerem.
  • MF zmieniło wczoraj szyfrowanie przesyłanych deklaracji. Należy pobrać nową wersję programu bcEdek.

Wersja 26.01.020 (03.03.2026)

  • Poprawa błędu. Pewien rodzaj korekt nie pozwalał zadekretować stawek ryczałtu. (gdy na korekcie faktury sprzedaży były tylko korygowane pozycje tzn, nie było pozycji przed korektą, nie było pozycji po korekcie tylko same korekty pozycji).
  • Częste pytanie od użytkowników, gdzie można zobaczyć znaczniki BFK, OFF, DI. Otóż nigdzie ich nie prezentujemy, tylko umieszczamy w pliku jpk_v7M ,v7K wg reguły którą opiszemy niżej. Należy pamiętać że te znaczniki są obowiązkowe (umieszczamy zawsze tylko 1 znacznik)
  • Dla sprzedaży. Jeżeli w danych firmy wpisano datę począwszy od której KSeF jest dla firmy obowiązkowy to znaczniki dla dokumentów po tej dacie umieszczane są w pliku jpk wg zasady:
    • Nr KSeF. Umieszczamy go jeśli dokument posiada taki numer
    • OFF. Umieszczamy go jeśli faktura nie posiada numeru KSeF, a nabywcą jest firma z numerem NIP.
    • BFK. Umieszczamy go jeśli faktura pozbawiona jest numeru KSeF a nabywcą jest konsument.
    • DI. W pozostałych przypadkach. Np. Dokument wewnętrzny.
  • Gdy sprzedaż odbywa się przed obowiązkiem KSeF oraz dla faktur zakupowych:
    • Nr KSef. Jeśli dokument posiada taki numer
    • BFK. Jeśli dokument jest fakturą i nie posiada nr KSeF. (czyli jest fakturą w wersji elektronicznej lub papierowej)
    • DI. W pozostałych przypadkach.
  • W przyszłości udostępnimy możliwość podstawienia znacznika.
  • Poniżej cytat z broszury informacyjnej MF ze stycznia 2026r
    • OFF Oznaczenie dotyczy faktury, o której mowa w art. 106nf ust. 1 ustawy, tj. faktury wystawionej w trybie awarii KSeF. Na dzień złożenia ewidencji faktura nie ma jeszcze przydzielonego numeru identyfikującego tę fakturę w KSeF. Podatnik nie ma obowiązku dokonania korekty ewidencji JPK_VAT po uzyskaniu numeru KSeF.
    • BFK Oznaczenie dotyczy faktury elektronicznej oraz faktury w postaci papierowej, które zostały wystawione poza KSeF, np. faktura na rzecz konsumenta lub faktury wystawione przed obowiązkiem fakturowania za pośrednictwem KSeF. Oznaczenie należy stosować także do faktur wystawionych w trakcie awarii całkowitej KSeF (art. 106ng ustawy).
    • DI Oznaczenie dotyczy dowodu innego niż faktura, dla której istnieje obowiązek wystawienia za pośrednictwem KSeF.

Wersja 26.01.019 (02.03.2026)

  • Usunęliśmy błąd, który w pewnych sytuacjach uniemożliwiał zaksięgowanie poprawnego dokumentu z bufora zakupów KSeF. Tabela z dekretacją dokumentu zawierała nieznane nam obecnie znaczniki. Nie znaleźliśmy powodu ich obecności, więc program instalacyjny po prostu usuwa niepoprawne rekordy. Być może jeśli problem się powtórzy będziemy mogli zidentyfikować przyczynę na razie nie dało rady.
  • Dla podatników zwolnionych z VAT program księgował dokumenty w kwocie netto. W zasadzie użytkownik powinien w parametrach zdefiniować, że jego wszystkie zakupy związane są wyłącznie ze sprzedażą zwolnioną, tym niemniej z drugiej strony u podatników zwolnionych powinniśmy ignorować wprowadzony parametr i księgować faktury w kwotach brutto. Tak też będziemy od tej wersji robić.
  • Dla faktur wystawiony przez biuro w KSeF mamy dwie niezależne numeracje. Jedna dla faktur i druga dla ich korekt. Ta sytuacja uniemożliwiała nam przesłanie faktur i korekt do KSeF, bowiem wymagana tam jest unikalność numeru faktury. Np. jeśli wysłaliśmy fakturę o numerze 1/2026 do ksef to nie było możliwości wysłania korekty faktury o numerze 1/2026. Dlatego numer faktury poprzedzamy literą F, a numer korekty literą K. Wydruki tych faktur nie miały oznaczenia F/K w numerze. Od tej wersji będą miały, o ile mają numer KSeF i nie będą miały, jeśli są bez numeru KSeF.
  • Odblokowaliśmy możliwość wysłania faktury do KSeF przez biuro dla klienta z kartoteki kontrahentów nie posiadającego numeru NIP.

Wersja 26.01.018 (01.03.2026)

  • Na pierwszej formatce w buforze zakupów umieściliśmy opis zdarzenia. Można go wybrać z listy myszą, lub dopisać klawiszem ENTER. Jeśli zaznaczono jakieś dokumenty wprowadzony opis można podstawić pod zaznaczone dokumenty lub tylko do bieżącego.
  • Dodaliśmy import dokumentów z Apteki (Kamsoft) w formacie KS-AOW .. .xml. Importujemy wyłącznie zakupy i ich korekty.
  • Poprawiliśmy wiele drobnych błędów związanych z dekretowaniem zakupów i sprzedaży. Np. przypisanie do zakupów towarów handlowych opisu zdarzenia "zakup samochodu", albo poprawienie groszówek, gdy stopka faktury różniła się od sumy pozycji (to oczywiście może wystąpić przy rozbiciu faktury na różne zdarzenia lub księgowaniu tylko części pozycji), ale nie powinno, gdy całość faktury zaliczona jest do jednego zdarzenia.
  • Niestety otrzymujemy przykłady faktur z którymi nie można nic zrobić. Np. z polskimi znakami zakodowanymi w niewiadomym standardzie, albo Korekty z których nie wynika żadna korekta. W początkowym okresie takie sytuacje będą się zdarzać. Ale trzeba informować producenta oprogramowania o błędach inaczej faktury nigdy nie będą wyglądać poprawnie. W tym celu dodaliśmy funkcjonalność polegającą na zapisaniu faktury w pliku faktury ustrukturyzowanej (tak jakby to zrobić na portalu MF). Aby zapisać fakturę do pliku trzeba ustawić belkę na nagłówku faktury (główna gałąź drzewa) i wcisnąć klawisz Ctrl+F12. Następnie program poprosi o wskazanie miejsca na dysku, gdzie trzeba zapisać fakturę. Taką fakturę można wysłać do producenta lub do klienta, który korzysta z oprogramowania producenta. Można też wysłać podgląd MF faktury po zapisaniu jej do pliku pdf (najlepiej wybrać wydruk - Ctrl+P a potem wybrać drukarkę "Zapisz do pdf".

Wersja 26.01.016 (26.02.2026)

  • Przy przeglądaniu faktury wystawionej w KSeF dodaliśmy możliwość przewijania jej o stronę (PgDn, PgUp) lub na sam koniec (Ctrl+PgDn) lub początek (Ctrl_PgUp) strony. Dotyczy długich faktur. Klawisze będą aktywne tylko gdy okno przeglądania otrzyma Focus (będzie aktywne po kliknięciu myszą w jego wnętrze).
  • Dodatkowo (tymczasowo do czasu aż nie zaprojektujemy innego Okna przeglądania), gdy okno przeglądania będzie aktywne klawiszami Up i Down (kursor w górę lub w dół) będzie można zmienić wysokość okna przeglądania.
  • Poprawa błędu. Dotychczas nie było czasu, aby dodatkowo skontrolować, czy dokumenty księgowane z bufora KSeF do ewidencji w księdze naruszają zasadę nieksięgowania w zamkniętym miesiącu lub w dacie wywołującą kolizje z datami dokumentów które mają już nadane numery. Pewnie przyjdzie czas, że numerów nie będziemy w ogóle nadawać (przecież nie ma takiego obowiązku), ale problem przedyskutujemy po 1 kwietnia, gdy wszyscy będą już w Ksef. Na razie wspomniany wyżej błąd spowodował dziwne zachowanie się programu w sytuacji gdy wystawiono fakturę w lutym za usługi wykonane w zeszłym roku. W tej sytuacji wobec braku kontroli dat dokument dopisał się do księgi z datą z roku 2025. Ponieważ prawie nigdzie nie jest widoczny nie można go ani usunąć ani poprawić. Program instalacyjny zmieni takiemu dokumentowi datę na: albo pierwszą możliwą do przyjęcia albo na datę KSef (przyjmie większą datę)
  • Naprawa błędu powstałego przy instalacji na nowy rok. Ksp dla podatników rozliczających się metodą kasową w VAT nie przenosił informacji o konieczności wyksięgowania niezapłaconej faktury wystawionej osobie fizycznej po 180 dniach od terminu zapłaty. Program instalacyjny naprawia ten problem.
  • Poprawa błędu z związanego z wysyłaniem jpk_kpir. MF zmienił schemat i księgi nie dało się wysłać.
  • Na fakturach wystawionych przez biuro i wysłanych do Ksef dodaliśmy możliwość wydruku Numeru KSef. Numer drukuje się wraz z nazwą serwera który nadał jej identyfikator.

Wersja 26.01.015 (24.02.2026)

  • Dodaliśmy podgląd faktury KSeF w buforze sprzedaży a także:
    • W ewidencji sprzedaży i zakupów
    • W księgowaniu
    • We wszystkich dokumentach
    • W opcji zatwierdzania VAT
    • W ewidencji sprzedaży i zakupów VAT
    • Przy przeglądaniu tabeli jpk_vat (sprzedaży i zakupów)
  • W buforze zakupów i sprzedaży podgląd dokumentu następuje po wciśnięciu klawisz TAB, ponieważ klawisz ten od zawsze w innych opcjach programu pełni inne funkcje (np. w ewidencji zakupów zamienia w tabeli dokumentów kwotę netto na brutto i odwrotnie, w księgowaniu powoduje nadanie numeru dokumentowi) więc dodaliśmy wywołanie podglądu również po naciśnięciu klawiszy "ALT+V". Tam gdzie to możliwe działają 2 klawisze TAB i ALT+V, a tam gdzie klawisz TAB jest już "zajęty", podgląd wywoła jedynie klawisz ALT+V.
  • Przy podlądzie dokumentu, jeśli klikniemy w okno podglądu (co spowoduje, że stanie się aktywnym oknem  otrzyma focus) będziemy mogli przewijać długie dokumenty przy pomocy kółka przewijania myszy (scrollem). Ta opcja będzie aktywna jedynie wtedy gdy dokument będzie dłuższy niż wyświetlające go okno.
  • Mieliśmy już zamiar usunąć parametry dekretacji w zakupach, bowiem mogą one przysporzyć wielu błędów, jednak zrezygnowaliśmy, bowiem w niektórych przypadkach mogą być użyteczne. Zalecamy jednak aby w przypadku, gdy firma ma różnie dekretowane dokumenty, i brak jest zdecydowanej przewagi jednej dekretacji nad innymi, aby ustawić w programie brak wstępnej dekretacji. Dodatkowo przypisaliśmy bardziej restrykcyjne parametry auto dekretacji związanej z uczeniem się programu od operatora. Jak wiemy, Ksp gromadzi informacje o dekretacji w związku z nabyciem od konkretnego sprzedawcy. Obecnie tylko wtedy przypisze dekretacje do dokumentu, jeśli przynajmniej 80% dekretowanych pozycji przypadało na dany dekret powiązany ze sprzedawcą.
  • Dodaliśmy możliwość po wybraniu filtra "Pokaż dokumenty zaksięgowane" usunięcia znacznika księgowania dla zaznaczonych faktur. Dotychczas można to było zrobić jedynie pojedynczo. Teraz, jeśli Ksp zauważy, że faktury są zaznaczone zaproponuje usunięcie powiązania z ewidencją księgową dla wszystkich zaznaczonych.
  • Rozwiązaliśmy prawdopodobnie problem filtrowania faktur, które chcemy pobrać z KSeF do danej firmy. Otóż w wielu przypadkach (np. apteki, sklepy detaliczne) podatnik prowadzi wiele punktów sprzedaży i każdy z nich prowadzony jest w Ksp jako odrębna firma. Do tej pory do każdej z nich wprowadzane były dokumenty odnoszące się do danego punku sprzedaży, aby podatnik mógł mieć informacje o ich zyskowności. Biuro rachunkowe zakładało dodatkową firmę, w której łączyło wszystkie dokumenty z poszczególnych punktów sprzedaży i z tej firmy składało deklaracje i obliczało podatki vat i dochodowy. Obecnie pobierając do danej firmy faktury z KSeF jedynym parametrem jest numer NIP podatnika i ewentualnie zakres czasowy. Tak więc ponieważ wszystkie punkty sprzedaży mają ten sam NIP, z KSeF pobierane są za każdym razem wszystkie faktury. MF wprowadziło do faktury ustrukturyzowanej oprócz danych sprzedawcy i nabywcy dodatkową grupę danych nazwanych Podmiot3. Liczba takich grup (Podmiot3) jest ograniczona i wynosi maksymalnie 100. Jakie dane zawiera Podmiot3.
    • Identyfikator. To pole musi być wypełnione i może zawierać jeden z poniższych parametrów
      • NIP - krajowy lub zagraniczny
      • Identyfikator wewnętrzny. Identyfikator składa się z numeru nip kreski i wewnętrznego 5 cyfrowego numeru. Może się nim posługiwać np. pracownik firmy (każdy może mieć inny)
      • Brak ID. Podmiot3 może nie mieć żadnego z powyższych, ale wtedy faktura zawiera informacje, że Podmiot3 nie posiada identyfikatora.
    • Nazwa. To dowolna nazwa opisująca Podmiot3. Możemy w niej wpisać cokolwiek (jeśli wystawiamy fakturę) lub poprosić sprzedawcę o wpisanie czegokolwiek jeśli jesteśmy nabywcą.
    • Adres. Można wpisać dowolną informację niekoniecznie związaną z adresem
    • Nr klienta. Tu również można wpisać dowolną informację
  • Tak więc Podmiot3 może zawierać pewne informacje, które będą użyteczne przy pobieraniu faktur sprzedaży i zakupów. Ważne aby te same zasady obowiązywały w obu przypadkach.
  • W Ksp dodaliśmy punkt w menu KSeF pozwalający zdefiniować filtrowanie faktur. Jeżeli dana faktura spełni warunki filtra dla przynajmniej jednego spośród maksymalnie 100 Podmiotów3 to zostanie zaimportowana do bufora KSeF. Na formatce z parametrami filtra można zdefiniować filtrowania na 4 wymienione wyżej pola. Jeśli dane pole jest nieistotne z punktu widzenia filtrowania nalęzy wybrać dla niego opcję "Bez znaczenia". Generalnie dla każdego pola mamy możliwość przyporządkowania mu jednego z następujących warunków:
    • Bez znaczenia. Oznacza, że ten warunek nie będzie sprawdzany. W szczególności, jeśli każde pole będzie miało tak ustawiony warunek, to żaden filtr nie będzie zastosowany przy pobieraniu. Ten warunek w zasadzie oznacza, że dane pole zawsze spełnia warunek.
    • Zawiera frazę. Ten warunek oznacza, że dane pole spełni warunek jeśli będzie zawierało wprowadzoną w konfiguracji frazę. Np. Jeśli wpiszemy jako warunek występowanie frazy "Sklep 1", a potmiot3 będzie miał w danym polu wpisane (np. w nazwie, adresie, nr klienta) "punkt sprzedaży sklep1, to warunek zostanie spełniony. Ksp zawsze każdą frazę przed sprawdzeniem zamieni na duże litery i pozbawi ją spacji. To samo zrobi z porównywanym polem. A więc w tym przypadku sprawdzi czy fraza SKLEP1 występuje w polu zawierającym PUNKTSPRZEDAŻYSKLEP1 - w przykładzie tym warunek zostanie spełniony.
    • Nie zawiera frazy. Ten warunek jest zaprzeczeniem powyższego. Warunek zostanie spełniony jeśli badane pole nie będzie zawierało wprowadzonej frazy
    • Jest równe. Warunek oznacza, że jedynie pole zawierające dokładnie taką treść jak fraza zostanie uznane za spełniające warunek.
  • Generalnie założyliśmy, że użytkownik wybierze jedno pole w celu zdefiniowania warunku filtrowania. Pozostałe ustawi jako "Bez znaczenia". Nic jednak nie stoi na przeszkodzie, aby założyć warunek złożony na kilka pól Podmiotu3. Ksp uzna, że Podmiot3 spełnia warunek, aby fakturę dopisać do bufora tylko wtedy jeśli wszystkie wprowadzone warunki będą spełnione.
  • Jeszcze jedna uwaga. Moglibyśmy chcieć, aby faktura została dopisana do bufora jeśli w polu nazwa wystąpi fraza "sklep1" albo "sklep2" albo "magazyn-1". Taki złożony warunek należy zapisać jako sklep1|sklep2|magazyn-1|. Gdybyśmy dla powyższej frazy wybrali warunek "Nie zawiera frazy" to byłby spełniony, jeśli w polu nazwa nie wystąpiłaby ani fraza "sklep1", ani "sklep2", ani "magazyn-1". Czyli żadna z wpisanych fraz.
  • Wpisywana fraza nie może mieć mniej niż 4 znaki.

Wersja 26.01.014 (20.02.2026)

  • Przy imporcie dokumentów epp z programu Nexo, uwzględniono nietypowe umieszczanie danych kontrahenta (Ze znakiem końca linii wewnątrz nazwy).
  • Przy wysyłaniu wystawionych faktur korygujących do KSEF Ksp nie przesyłało przyczyny korekty i niepoprawnie oznaczało typ korekty.
  • W opcji aktualizacja danych na podstawie ubiegłego roku dodano aktualizację ewidencji OSS. ("7/8/G.Aktualizuj OSS")
  • Poprawiono błąd. Przy edycji bufora zakupów KSeF, Ksp dla wydatku samochodowego pobierało listę aktywnych samochodów zakładając, że poprawny numer rejestracyjny ma nie więcej niż 8 znaków. Jak się okazuje poprawny numer rejestracyjny może mieć 8 znaków.
  • Poprawiono błąd wczytania sprzedaży OSS z pliku amazona.

Wersja 26.01.013 (18.02.2026)

  • Przy przenoszeniu ewidencji z modułu OSS do księgi, w tabeli dokumentów nie pokazywały się kwoty. Instalacja naprawia ten problem.

Wersja 26.01.012 (17.02.2026)

  • Poprawa błędu, który nie pozwalał wpisać zapłat do Refundacji z aptek.

Wersja 26.01.011 (16.02.2026)

  • Wersja 008 wygenerowała błędy związane z importem dokumentów z programów fakturujących polegające na pominięciu oznaczenia dokumentu, że jest fakturą. Skutkiem tego do księgi dokumenty przenosiły się bez oznaczenia typu dokumentu a do vatu nie przenosiły się wcale. Trzeba po zainstalowaniu nowej wersji usunąć wcześniej zaimportowane dokumenty i zaimportować je jeszcze raz.
  • Dokumenty związane z eksploatacją samochodu osobowego które były wprowadzone do księgi w zeszłym roku ale z oznaczeniem, że w ewidencji VAT mają być rozliczane w roku 2026, miały kwotę netto w wysokości jej rzeczywistej wartości, a nie połowy (proporcjonalnie do odliczanego podatku VAT.
  • Ostatnio mamy wiele pytań związanych z korektą roczną. Wyjaśniamy, że korekta może być korzystna lub niekorzystna dla podatnika, a więc w pierwszym przypadku zwiększająca podatek naliczony lub zmniejszająca w drugim. Korekty korzystne Ksp zawsze będzie obliczał i umieszczał na deklaracji bez względu na dodatkowe okoliczności. Natomiast korekty niekorzystne czasem Ksp będzie przyjmował jako równe 0, taki przywilej daje nam ustawa, ale pod pewnymi warunkami. Otóż, jeśli różnica między proporcją stosowaną w trakcie roku 2025 (jeśli dotyczy pozostałych zakupów lub środków do 15tys.) i proporcją ostateczną dla roku 2025 po jego zakończeniu wynosi 1 lub 2 punkty procentowe to podatnik może nie dokonywać tej korekty, jeżeli jego korzyść wynikająca z zaniechania korekty nie przekracza 10tys. Gdy liczymy korekty dla środków korygowanych w okresie 5 lub 10lat, pod uwagę będziemy brać jedynie te środki, których proporcja w roku nabycia i proporcja ostateczna za 2025 będzie różniła się o nie więcej niż 2 punkty procentowe.

Wersja 26.01.008 (14.02.2026)

  • W opcji przeglądania dokumentów bez numer KSeF, dodaliśmy możliwość zmiany Serwera który nadał numer KSeF z serwera Demo na serwer produkcyjny (klawisz "P") oraz opcję usunięcia numeru Ksef jeśli oznaczony jest jako pochodzący z Serwera DEMO (klawisz DEL).
  • Poprawiliśmy błąd przy pobieraniu danych o przychodzie z roku 2025, jako podstawy składki zdrowotnej (firmy na skali lub liniowym). Ksp kończył działanie z błędem systemowym  błąd powstał w wersji 007.
  • Poprawiliśmy błąd dotyczący aktualizacji ewidencji (księga i VAT) na podstawie 2025. Problem dotyczył zakupów które wprowadzone zostały do księgi w 2025 roku ale z datą VAT na rok 2026. Ksp podczas aktualizacji na podstawie ubiegłego roku przepisywał dokument zakupu z roku 2025 na rok 2026, ale bez części ze stawkami Vat. Obecnie wykonanie tej aktualizacji dopisze brakujące stawki.
  • Częściowo poprawiliśmy błąd związany z wyliczeniem rocznej korekty od zakupionych środków trwałych, zgodnie z art.90,91 ustawy. Problem dotyczył zakupionych samochodów osobowych, których użytkowanie było związane ze sprzedażą opodatkowaną i zwolnioną. Ksp w miesiącu zakupu obliczało poprawną kwotę do odliczenia wynikającą ze współczynnika poprzedniego roku, jednak do Historii "A/4/3.Korekty Art.91 - historia" przekazywało kwotę podatku naliczonego w wysokości podatku odliczanego. Przykładowo: współczynnik sprzedaży opodatkowanej do zwolnionej za rok poprzedni wynosi 10%. Samochód osobowy kosztuje 1000zł netto i podatek Vat 230zł. Kwoty netto i podatku naliczonego wynoszą odpowiednio 500 i 115 zł. Natomiast kwoty netto i podatku odliczonego wynoszą 50zł i 11,50. Błąd polegał na tym, że do historii Ksp przekazywało kwoty podatku naliczonego i odliczonego w wysokości 11.50. To ma oczywiście wpływ na roczną korektę. Niestety obecnie jedyny sposób na naprawienie tej sytuacji, to ręczna zmiana kwot podatku naliczonego za lata wcześniejsze niż 2026 w opcji z historią. Dodatkowo trzeba przeliczyć deklarację za styczeń i luty 2026. Podatek odliczony jest w poprawnej wysokości. Błąd powstał prawdopodobnie w roku 2020.
  • Zaktualizowaliśmy import dokumentów z pliku jpk_V7M.xml i V7K.xml dla nowej struktury (z numerami KSeF). Zaktualizowaliśmy również wczytanie archiwalnych plików Jpk do opcji w której tworzymy plik jpk_vat z deklaracją.
  • Dodaliśmy import dokumentów z Subiekta w wersji 1.12. Wersja ta zawiera numer ksef dokumentu. Dodatkowo uwzględniliśmy fakt, że niektóre programy tworzyły plik, prezentując w nim poszczególne bloki w innej kolejności niż opisana w strukturze edi++.
  • W opcji z wydrukiem folio dodaliśmy jeszcze jedno zestawienie kontrolne. Tym razem wydruk zawiera wyłącznie zakupy za miesiąc. Jeśli ten wydruk miałby zawierać inne kolumny potrzebna nam jest informacja zwrotna.

Wersja 26.01.007 (12.02.2026)

  • Poprawiono błąd. Przy pobieraniu przychodu właściciela z zeszłego roku celem określenia podstawy stałej składki zdrowotnej w roku 2026 nie uwzględnialiśmy sprzedaży majątku i okresów zawieszonej działalności.
  • Dla faktur bez pozycji, jedynie z rozpisaną stopką, Ksp nie radził sobie z zaksięgowaniem i zadekretowaniem dokumentu w buforze KSeF. Poprawiliśmy.
  • Niektóre faktury ustrukturyzowane, miały ponumerowane pozycje począwszy od numeru np. 300000000. Ksp nie było przygotowane na takie sytuacje i nie potrafiło pobrać takiej faktury do bufora. Podobnie jeśli poszczególne pozycje faktury nie posiadały wartości netto lub brutto, a jedyną wartością w pozycji była cena jednostkowa.
  • Zabezpieczyliśmy się na okoliczność występowania w fakturach ustrukturyzowanych komentarzy wystawców faktur umieszczonych niezgodnie ze standardami xml.
  • Poprawa błędu przy przekazaniu pobranych faktur z bufora Saldeo do ewidencji (nie zawsze).
  • Dodaliśmy nową opcję "2/Dokumenty bez numeru KSeF". W tej opcji program pokaże dokumenty z księgi bez nadanego numeru KSeF. Numer będzie można wpisać lub wkleić ręcznie. W opcji księgowania i przeglądania dokumentów które są tylko w ewidencji VAT (opcje 2/4 i 2/5), udostępniliśmy do Edycji nr Ksef.
  • W ewidencji OSS dodaliśmy przekazywanie danych do księgi przychodów lub ewidencji ryczałtowca. Dotychczas księgowano dokument zbiorczy, obecnie powinna być do księgi przekazana każda faktura. Dla ewidencji ryczałtowej dodaliśmy opcję (F8) podstawiania pod zaznaczone dokumenty stawki ryczałtu. Jeśli stawki nie zostaną wybrane Ksp podstawi domyślnie stawkę 3%. Zmieniliśmy również wydruk zestawień.
  • W firmach ryczałtowych, usprawniliśmy algorytm aktualizacji ewidencji na podstawie roku 2025 w księdze i VAT. W niektórych przypadkach przy bardzo dużej ilości dokumentów, ten proces trwał b. długo. (analizowaliśmy przypadek 70 tysięcy faktur).

Wersja 26.01.006 (05.02.2026)

  • W opcji "8/3/6.Certyfikat dostępu do KSeF" dodaliśmy możliwość (F10) przypisania wybranym użytkownikom Certyfikatu zalogowanego użytkownika. Opcja ta dostępna jest wyłącznie dla SuperAdministratora. Dodatkowo dodaliśmy opcję usunięcia certyfikatów wybranym użytkownikom jeżeli posiadają oni certyfikat SuperAdministratora przypisany np. Klawiszem (F10). Usunięcie certyfikatów następuje po naciśnięciu klawisza F12 i i wybraniu zaznaczonych użytkowników.
  • Dodaliśmy wydruk KPiR wg nowego wzoru. W zasadzie nie znamy biura, które prowadziłoby księgi na papierze, jednocześnie prowadząc księgowania w Ksp. Tym nie mniej dodaliśmy. Obecnie mamy 2 wzory księgi. Jeden jednoczęściowy drukowany na poziomej kartce z wybranym informacjami  niezgodny ze wzorem księgi. Wydruk ten udostępniliśmy dla celów kontrolnych i drugi zgodny ze wzorem, drukowany na poziomych kartkach w dwóch częściach (lewa z przychodami i prawa z pozostałymi informacjami. Jeżeli drukarka ma możliwość druku typu DUPLEX, to tak wydrukowaną księgę można zbroszurować, wówczas wyglądem będzie podobna do księgi zakupionej w księgarni.
  • Przy imporcie danych z Saldeo dodaliśmy import numeru KSeF.
  • Usunęliśmy błąd występujący przy przekazywaniu przychodów do ewidencji ryczałtowej jeśli wybrano stawkę ryczałtu, która nie była zaznaczona w instalacji jako występująca w działalności podatnika.
  • Poprawiliśmy błąd. Przy przekazywaniu danych o sprzedaży do ewidencji Vat zapomnieliśmy o stawce 5%.
  • Poprawa błędu: Przy zmianie ilości w pozycji faktury, Ksp zamieniał netto z podatkiem Vat.
  • Przy tworzeniu Jpk_V7M /V7K, jeżeli wprowadzono dokument uniwersalny dokumentujący złe długi w przychodach, to Ksp wpisywał w pliku Jpk zamiast terminu płatności, datę wystawienia dokumentu.
  • Przy wypłatach do umowy opodatkowanych ryczałtem, które wykazujemy na IFT-1R dodaliśmy brakujący rodzaj przychodu (Dywidendy).
  • Nad czym pracujemy (na najbliższe dni)?
    • Nad pominięciem aplikacji SaldeoPulpit w komunikacji z Saldeo. Obecna wersja SaldeoPulpit korzysta z oprogramowania java w wersji 64bit. Ponieważ firma Oracle nie planuje wydania wersji 32 bitowej, Saldeo Pulpit nie będzie pracować na komputerach z Windowsem 10 w wersji 32bit i starszych komputerach.
    • W opcji wszystkie dokumenty dodamy opcję odfiltrowania dokumentów bez numeru KSeF w celu ręcznego przypisania im tego numeru.
    • W Edycji bufora zakupowego dodamy filtrowanie dokumentów wybranego kontrahenta.
    • W parametrach importu faktur z Ksef dodamy możliwość pobrania tylko dokumentów zawierających w bloku Podmiot3 wprowadzonej sekwencji znaków przez użytkownika. Np. Załóżmy, że podatnik ma kilka sklepów i chce aby biuro informowało go o dochodowości poszczególnych punktów sprzedaży. Obecnie importując dane dla wybranego sklepu pobiorą się wszystkie faktury z nipem podatnika. Jeżeli na fakturze wystąpi podmiot trzeci z np. z ID wewnętrznym, lub z nazwą np. SKLEP1, to Ksp odfiltruje tylko takie dokumenty które zawierają napis SKLEP1 lub konkretne Id wewnętrzne. Możliwości filtrowania będzie nieco więcej.
    • Dla faktur wystawionych w walucie obcej planujemy przekazać je do rozrachunków walutowych.
    • W ewidencji OSS, zrobimy przekazanie pojedynczych dokumentów do księgi. Obecnie tworzymy dowód zbiorczy.
    • W buforze zakupów i sprzedaży dodamy możliwość przypisania opisu zdarzenia gospodarczego
    • W ewidencji dokumentów w Ksp będziemy sukcesywnie dodawać funkcjonalność związaną z podglądem faktury, jeśli będzie miała nr KSeF.

Wersja 26.01.005 (02.02.2026)

  • W module wysyłania deklaracji RCA i RSA wydłużono długość pola z nazwiskiem osoby ubezpieczonej do 30-tu znaków.
  • Poprawiliśmy błąd który powodował, że pomimo ustawienia, że bieżącym serwerem jest Produkcyjny, po wybraniu innej firmy, ustawienie ponownie przywracało serwer DEMO.
  • Program instalacyjny ustawi dla wszystkich firm, że bieżącym serwerem KSEF będzie serwer produkcyjny. (oczywiście można to zmienić).
  • Dodaliśmy w menu KSeF dwie opcje:
    • Pierwsza sprawdza dostępność bramki Ksef
    • Druga pozwala usunąć w bieżącej firmie wszystkie faktury z buforów sprzedaży i zakupów lub tylko te, które zostały pobrane z bramki DEMO (serwera przedprodukcyjnego).

Wersja 26.01.004 (27.01.2026)

  • Zaktualizowaliśmy wynagrodzenie wraz z wypłatami z zysku za IV kw 2025. Oznacza to, że zaktualizowano również progi dla podstaw zdrowotnego na ryczałcie i podstawę składek na ubezpieczenie zdrowotne osoby współpracującej.
  • Nowe wersje deklaracji IFT-1 i IFT1R.
  • Wiele zmian związanych z KSeF (na razie niewidocznych dla użytkownika), Poza jedną, podczas przeglądania bufora z zakupami, można nacisnąć klawisz TAB który włącza/wyłączna okno podglądu faktury.
  • Ponieważ przy instalacji na nowy rok nie przenieśliśmy dowodów wewnętrznych (dokumenty za klienta), dodaliśmy w aktualizacji danych na podstawie roku 2025 opcję aktualizującą.

Wersja 26.01.003 (14.01.2026)

  • W związku z wprowadzeniem ustawy regulującej obrót kaucjonowanymi opakowaniami zwrotnymi przy udziale 3-go podmiotu zwanego Operatorem (lub Reprezentantem) dodaliśmy nowy dokument w punkcie "A/5/9.Zwrot kaucji za opakowania". Obecnie bezpośrednim odbiorem opakowań zwrotnych zajmują się operatorzy, którzy instalują automaty pozwalające zwrócić butelkę lub pet jeśli zostały odpowiednio oznakowane, albo w inny uzgodniony sposób odbierają opakowania od detalisty/hurtownika. Wszystko rozpoczyna się od Producenta lub importera napojów zwanego w ustawie podmiotem wprowadzającym napoje w opakowaniach zwrotnych na Polski rynek. Producent po wyprodukowaniu napojów przekazuje je hurtownikowi lub detaliście doliczając do ceny napoju kaucję za opakowania bez pobierania od tej kaucji podatku VAT. Kwotę pobranej od hurtownika kaucji Producent przekazuje Operatorowi. Operator z otrzymanych kaucji finansuje cały proces rozliczania kaucji. Instaluje Automaty lub w inny sposób odbiera opakowania zwrotne wypłacając kaucję za zwracane opakowania. Na koniec roku porównuje kwotę otrzymanych kaucji od producenta z kwotami wypłaconymi konsumentom. Jeżeli kwota wypłaconych kaucji jest mniejsza od kwoty otrzymanej od producenta, oznacza to, że nie wszystkie opakowania zwrotne wróciły do operatora. Operator od tej różnicy ustala kwotę podatku VAT licząc go od kwoty kaucji brutto, w podziale na stawki podatku wg których Producent sprzedawał napoje. Tę kwotę podatku Operator wpłaca do urzędu skarbowego na mikrorachunek Producenta i przekazuje Producentowi informację o wpłacanej kwocie zgodnie z ustawą opakowaniową. Producent informację o kwocie zwróconej do US umieszcza w nowym polu deklaracji VAT-7M/7K o numerze 360. Kwota ta pomniejszy podatek należny producenta. Tę właśnie kwotę należy wpisać w nowym dokumencie VAT. Producent dodatkowo, zwykłym dowodem wewnętrznym wykazuje niezwrócone opakowania zwrotne rejestrując w polach P_15 do P_20 kwoty netto i podatku należnego od opakowań które do niego nie wróciły. Jak z tego wynika Producent w zasadzie nie płaci podatku od obrotu opakowaniami zwrotnymi.
  • Na formatce nr 1 z danymi firmy w opcji "8/1/1.Edycja danych firmy" umieściliśmy w dolnej części formatki informację o dacie obowiązkowego KSeF. Począwszy od tej daty faktury, które będą miały inną datę wystawienia (P_1) niż data wynikająca z numeru KSeF zostaną wykazane w ewidencji jako OFFLINE. Faktury wystawione przed ta datą, które nie trafiły do ewidencji KSeF zostaną oznaczone jako BFK, czyli elektroniczne lub papierowe. W pozostałych przypadkach dokumenty oznaczone zostaną symbolem DI.
  • Dodaliśmy nową deklarację VAT w wersji 17 (dla VAT-7K) i 23 dla VAT-7M. Wraz z deklaracjami dodaliśmy odpowiednio zmienione ewidencje jpk_vat w wersji 3. Na deklaracji Vat-7 zniknął termin zwrotu podatku w terminie 60dni.
  • W informacji podatkowej zmieniliśmy elektroniczne ewidencji księgi przychodów i ewidencję ryczałtowca na ewidencje odpowiednio w wersjach 3 i 4. Wydruki ewidencji pozostawiliśmy na razie w niezmienionej formie.
  • W menu KSeF dodaliśmy opcję sprawdzenia uprawnień dostępowych dla danej formy. Biuro może sprawdzić wybierając do kontekstu daną firmę, czy firma udzieliła uprawnień do wystawiania lub pobierania faktur.
  • Usunęliśmy wszystkie ewidencje i deklaracje VAT z okresu wcześniejszego niż październik 2020. To odchudziło bazę danych, ale też wydłużyło czas instalacji tej wersji programu.

Wersja 26.01.002 (08.01.2026)

  • Poprawa błędu związanego z obieranie umów zlecenie z ubiegłego roku. Nie pobierały się rachunki.

Wersja 26.01.001 (01.01.2026)

  • Pierwsza wersja na rok 2026. Nie ma w niej istotnych zmian, poza powrotem do płacy minimalnej jako podstawy minimalnej składki zdrowotnej (w 2025 było 75% płacy minimalnej). Oraz zmianą ograniczeń zaliczania do kosztów uzyskania wydatków związanych z eksploatacją samochodu osobowego.
  • Dla samochodów osobowych dla których dotychczasowy odpis zaliczany do kosztów uzyskania nie mógł przekroczyć w okresie amortyzacji kwoty 150tys zł obecnie ograniczony jest kwotą 100tys, jeżeli emisja co2 dla samochodu jest większa lub równa 50 g/km. A więc miesięczna rata zaliczana w koszty jest procentem całej raty, który wynosi 100000/Podstawa odpisu*100% (jeżeli podstawa odpisu > 100tys). Ponieważ norma EURO6 dla nowych samochodów wynosi 93.6 g/km. Wiec praktycznie wszystkie samochody spalinowe będą miały ograniczenie odpisów w koszty kwotą 100tyś. Należy pamiętać, aby samochody kupione po 1 stycznia 2026 miały wpisany w kartotece środków trwałych odpowiedni limit.
  • Zmiana ograniczenia dotyczy również samochodów leasingowanych. Limit dla raty kapitałowej został obniżony ze 150tys do 100tys jeśli emisja co2 >= 50g/km.
  • Nowe ograniczenia dotyczą tylko spalinowych samochodów osobowy zakupionych lub leasingowanych (decyduje data zawarcia umowy) po 1 stycznia 2026 dla których emisja Co2 >= 50g/km.